题目1041:Simple Sorting

题目描述:

You are given an unsorted array of integer numbers. Your task is to sort this array and kill possible duplicated elements occurring in it.

输入:

For each case, the first line of the input contains an integer number N representing the quantity of numbers in this array(1≤N≤1000). Next N lines contain N integer numbers(one number per each line) of the original array.

输出:

For each case ,outtput file should contain at most N numbers sorted in ascending order. Every number in the output file should occur only once.

样例输入:
6
8 8 7 3 7 7
样例输出:

3 7 8

C++代码:

#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

vector<int> v;

int n;

int main(){
    while(cin>>n){
        for(int i=0;i<n;i++){
           int a;
           cin>>a;
           v.push_back(a);
        }
        sort(v.begin(),v.end());
        cout<<v[0];
        int m = v[0];
        for(int i=1;i<v.size();i++){
            if(v[i]!=m){
                cout<<" "<<v[i];
                m=v[i];
            }
        }
        cout<<endl;
        v.clear();
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值