D - Ignatius and the Princess IV

题目

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…..” feng5166 says.

Can you find the special integer for Ignatius?

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.

Output
For each test case, you have to output only one line which contains the special number you have found.

Sample Input
5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output
3
5
1

题意

给出N(奇)个数,这N个数里面要有某个数出现至少(N+1)/2 次(即该数占N个数里面一半以上). 如果有这样的数,就把它打印出来。

解析

算法是既然要占一半以上,所以要记录某数出现的次数,例如有这样的数a,出现了计数器就加1,出现与a不同的数计数器就减1,最后只要计数器值>0,则就是a。

代码

#include <stdio.h>
int a[1000000];
int main()
{
    int N;
    int time;
    int i;
    int ans;
    while (scanf("%d",&N)!=EOF)
    {
        time=0;                  //计数器

        for (i=0; i<N; ++i)
        {
            scanf("%d",&a[i]);

            if(time==0)          //这样就可以当time减到零时,表明当前数不是所要的数,要更换。
            {
                ans=a[i];
                time=1;
            }
            else if(ans==a[i]) //判断是不是所要的数,是time++,不是time--。
                ++time;
                else
                --time;
        }
        printf ("%d\n",ans);
    }
    return 0;
}
  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值