Big Number
As we know, Big Number is always troublesome. But it’s really important in our ACM. And today, your task is to write a program to calculate A mod B.
To make the problem easier, I promise that B will be smaller than 100000.
Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
Output
For each test case, you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521
1)秦九韶算法:IJKL = ((I * 10 + J)* 10 +K)10 + L;
2)(ab)%c == (a%c)(b%c) 、(a+b)%c == (a%c)+(b%c);
即 IJKL % B = ((I * 10 + J) % B 10 % B +K % B)% B * 10 % B + L % B;
实现
#include <cstdio>
#include <cstring>
using namespace std;
int main() {
int b;
char a[1005];
int sum = 0;
while (scanf("%s %d", a, &b) != EOF) {
sum = a[0] - '0';
int la = strlen(a) ;
// printf("%d\n", la);
for (int i = 1; i < la; ++i) {
sum = (sum * 10 + a[i] - '0') % b;
}
printf("%d\n", sum);
}
return 0;
}