Atlantis

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.
Input
The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.
Output
For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.
Sample Input
2
10 10 20 20
15 15 25 25.5
0
Sample Output
Test case #1
Total explored area: 180.00

题意

给了每个矩形的左下角,右上角坐标,计算这n个矩形的面积并。

思路

扫描线加线段树的模板题,开一个结构体记录四个值(x,y1,y2,flag);x为矩形的左边界时,flag为1,反之-1;
y1,y2为上下边界,这是扫描线所需的值,将每个矩形上下边界存入数组并排序,以2*n建树,将矩形的上下边界存入;
然后就通过扫描线从左至右扫描。
每次扫描到左边界cover+1,有边界-1,cove>0就计算此面积。

#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 220
double y[maxn];
struct LINE{
	double x,y_up,y_down;
	int flag;
}line[maxn];
struct node{
	double x,y_up,y_down;
	int flag,cover;
}a[maxn<<2];
int n;
bool cmp(LINE a,LINE b)
{
	return a.x<b.x;
}
void build(int k,int l,int r)
{
	a[k].x=0,a[k].flag=0,a[k].cover=0;
	a[k].y_down=y[l],a[k].y_up=y[r];
	if(l+1==r){
		a[k].flag=1;                       //将其叶子节点标为1
		return ;
	}
	int mid=(l+r)>>1;
	build(k<<1,l,mid);
	build(k<<1|1,mid,r);
}
double insert(int k,double x,double l,double r,int flag)
{
	if(r<=a[k].y_down||l>=a[k].y_up)return 0;
	if(a[k].flag){  										//进入叶子节点计算面积,此时的·上下边界相邻
		if(a[k].cover>0){                              
			double temp_x=a[k].x;
			double ans=(x-temp_x)*(a[k].y_up-a[k].y_down);
			a[k].cover+=flag;
			a[k].x=x;                                       ///将前面的x值记录
			return ans;
		}
		else {
			a[k].cover+=flag;
			a[k].x=x;
			return 0;
		}
	}
	double ans1,ans2;
	ans1=insert(k<<1,x,l,r,flag);
	ans2=insert(k<<1|1,x,l,r,flag);
	return ans1+ans2;
}
int main()
{
	int cnt=0;
	while(~scanf("%d",&n)&&n)
	{
		int id=0;
		while(n--)
		{
			double x1,x2,y1,y2;
			scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
			y[++id]=y1;
			line[id].x=x1,line[id].y_down=y1,line[id].y_up=y2;
			line[id].flag=1;
			y[++id]=y2;
			line[id].x=x2,line[id].y_down=y1,line[id].y_up=y2;
			line[id].flag=-1;
		}
		//printf("%d\n",id);
		sort(y+1,y+1+id);
		sort(line+1,line+1+id,cmp);
		//for(int i=1;i<=id;i++)printf("%lf\n",y[i]);
		build(1,1,id);
		double ans=0;
		for(int i=1;i<=id;i++){
			ans+=insert(1,line[i].x,line[i].y_down,line[i].y_up,line[i].flag);
		}
		printf("Test case #%d\nTotal explored area: %.2f\n\n", ++cnt, ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值