Balancing Act poj-1655

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1…N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:
在这里插入图片描述

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.
Input
The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.
Output
For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.
Sample Input
1
7
2 6
1 2
1 4
4 5
3 7
3 1
Sample Output
1 2

题意

一棵树,去掉一个点就会变成森林,计算去掉每个节点形成的最大子树的最少节点以及这个点的编号;
题意很绕,其实就是树的重心问题。

思路

开一个vector记录这棵树,然后再开一个二维数组dp(也可以开两个一维数组),dp[i][0]用来记录i节点的最大子树的节点个数,dp[i][1]记录i节点的子节点个数(包括本身)。
状态转移方程:
dp[i][1]=dp[i][1]+dp[son(i)][1];
dp[1][0]=max(dp[i][0],n-dp[i][1]);

#include<cstdio>
#include<vector>
#include<cstring>
#define maxn 100000
using namespace std;

int dp[maxn][2];
vector<int >g[maxn];
int n;

void dfs(int u,int fa)
{
	
	for(int i=0;i<g[u].size();i++){
		int v=g[u][i];
		if(v==fa)continue;
		dfs(v,u);
		dp[u][1]+=dp[v][1];
		dp[u][0]=max(dp[u][0],dp[v][1]);
	}
	dp[u][1]+=1;
	dp[u][0]=max(dp[u][0],n-dp[u][1]);//用总的节点数减去当前节点的子节点数是父节点的个数
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		memset(dp,0,sizeof(dp));
		scanf("%d",&n);
		for(int i=1;i<=n;i++)g[i].clear();
		for(int i=1;i<n;i++){
			int a,b;
			scanf("%d%d",&a,&b);
			g[a].push_back(b);
			g[b].push_back(a);
		}
		dfs(1,-1);
		int ans=dp[1][0],id=1;
		for(int i=1;i<=n;i++){
			if(ans>dp[i][0]){
				ans=dp[i][0];
				id=i;
			}
		}
		printf("%d %d\n",id,ans);
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值