HDU - 1004 Let the Balloon Rise

Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

本题题意:本题就是要让你找出出现次数最多的颜色,输入0退出。

本题思路:做一个map映射,一个储存颜色,另一个储存出现次数,找到出现次数最多的,映射出颜色即可。

AC代码如下:

#include<iostream>
using namespace std;
#include<string>
#include<map>
int main()
{
	string s,s1;
	int n;
	
	while (cin >> n&&n)
	{
		map<string, int>mp;
		
		while (n--)
		{	
			cin >> s;
			mp[s]++;
		//存储气球信息
		}
		int max1 = 0;
		//迭代map
		for (map<string, int>::iterator it = mp.begin(); it != mp.end(); it++)
		{
			if (it->second > max1)
			{
				max1 = it->second;
				s1 = it->first;
			}
		}
		cout << s1 << endl;
	}

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值