Dungeon Master

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S…
.###.
.##…
###.#

##.##
##…

#.###
####E

1 3 3
S##
#E#

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题目思路:

本题给出的是一个3D的迷宫可以选择上下左右以及向上一层或者下一层走共计六个方向,要找到最短的那条路,并且每走一个位置花费一分钟时间,如果走不出去则输出Trapped!这是一个典型的广搜问题我们用一个三维数组就能解决了。

AC代码如下:


#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int sx,sy,sz,ex,ey,ez;
const int maxn=100;
int vis[maxn][maxn][maxn];
char a[maxn][maxn][maxn]; 
int l,r,c;
int dir[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};

struct Node{
	int x,y,z;
}; 


bool bfs()
{
	queue<Node>que;
	Node n;
	n.x=sx;
	n.y=sy;
	n.z=sz;
	que.push(n);
	vis[n.x][n.y][n.z]=1;
	while(!que.empty())
	{
		Node n1=que.front();
		que.pop();
		for(int i=0;i<6;i++)
		{
			int dx=n1.x+dir[i][0];
			int dy=n1.y+dir[i][1];
			int dz=n1.z+dir[i][2];
			if(dx<0||dx>=l||dy<0||dy>=r||dz<0||dz>=c||a[dx][dy][dz]=='#'||vis[dx][dy][dz])continue;		
			vis[dx][dy][dz]=vis[n1.x][n1.y][n1.z]+1;
			if(dx==ex&&dy==ey&&dz==ez)return true;	
			n.x=dx;
			n.y=dy;
			n.z=dz;
			que.push(n);
	
		}
		
	}
	return false;	
}


int main()
{
	while(cin>>l>>r>>c)
	{
		memset(vis,0,sizeof(vis));
//		memset(a,0,sizeof(a));
		if(l==0&&r==0&&c==0)
		{
			break;	
	    }
		for(int i=0;i<l;i++)
		{
			for(int j=0;j<r;j++)
			{
				for(int k=0;k<c;k++)
				{
					cin>>a[i][j][k];	
					if(a[i][j][k]=='S'){
						sx=i;
						sy=j;
						sz=k;
					}
					if(a[i][j][k]=='E')
					{
						ex=i;
						ey=j;
						ez=k;		
				    }				
				}
			}
		//printf("\n");
		}
	
		//Escaped in 11 minute(s).    减去S初始的1 
		if(bfs())cout<<"Escaped in "<<vis[ex][ey][ez]-1<<" minute(s)."<<endl;							
		else cout<<"Trapped!"<<endl;		
	}
	return 0;
 } 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值