HDU1241 Oil Deposits

                                                               Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7709    Accepted Submission(s): 4514


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
 

Recommend
Eddy


解题思路:广度优先搜索,图的连通分量。

遍历图——>找到油田——>把油田群找出来——>标记、计数——>继续遍历——>遍历完成

只要相邻既是一起,也就是说,遍历方向有8个,所有相邻的都算。


#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int n,m;
char map[100][100];
int sum;
int dir[8][2]={1,0,1,1,1,-1,0,1,0,-1,-1,0,-1,1,-1,-1};      //8个方向
struct node
{
    int x;
    int y;
};
int inmap(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return true;
    return false;
}
void bfs(int x,int y)
{
    int i;
    node u,v;
    queue<node> q;
    u.x=x;
    u.y=y;
    q.push(u);
    while(!q.empty())
    {
        u=q.front();
        q.pop();
        for(i=0;i<8;i++)
        {
            v.x=u.x+dir[i][0];
            v.y=u.y+dir[i][1];
            if(inmap(v.x,v.y)&&map[v.x][v.y]=='@')     //是油田哦
            {
                map[v.x][v.y]='*';     //油田群遍历,标记
                q.push(v);
            }
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&n,&m)&&m)
    {
        sum=0;
        for(i=0;i<n;i++)
            scanf("%s",map[i]);
        for(i=0;i<n;i++)
        {
            for(j=0;j<m;j++)
            {
                if(map[i][j]=='@')      //找到油田
                {
                    sum++;
                    bfs(i,j);
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值