HDU4608 I-number

                                                                    I-number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1369    Accepted Submission(s): 554


Problem Description
The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1. y>x;
2. the sum of each digit of y(under base 10) is the multiple of 10;
3. among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.
 

Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 10 5.
 

Output
Output the I-number of x for each query.
 

Sample Input
  
  
1 202
 

Sample Output
  
  
208
 

Source
 

Recommend
liuyiding



解题思路:看给的时间,应该知道可以直接暴力解决,直接连续自加直到所有数字之和为10的倍数为止。本题涉及到达数,不能直接用某个数据类型存储,用数组模拟存贮即可,看到有大神用数组模拟万进制存储,在下不才,还处于小鸟阶段,只能做到数组十进制存储,容易理解。注意,本题坑爹的地方在:如果输入得数据中有前导零时,输出也要注意前导零,还要注意进位。




#include<stdio.h>
#include<cstring>
using namespace std;
char num[100005];
int main()
{
    int t;
    int sum;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        sum=1;
        num[0]='0';
        num[1]='0';
        scanf("%s",num+2);
        int n=strlen(num);
        for(i=0;i<n;i++)      //转换为数值存储
            num[i]=num[i]-'0';
        while(sum%10)     //检查10的倍数
        {
            sum=0;
            j=n-1;
            num[j]++;      //自加1
            while(num[j]>=10)   //进位
            {
                num[j-1]+=num[j]/10;
                num[j]%=10;
                sum+=num[j];
                j--;
            }
            for(;j>=0;j--)    //每个数字相加
                sum+=num[j];
        }
        i=1;
       if(num[i]==0)    //检查最高位是否进位
            i++;
        for(;i<n;i++)   //直接输出,不要避开前导0
            printf("%d",num[i]);
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值