HDU 4608 I-number

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4608

I-number

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3092    Accepted Submission(s): 1163


Problem Description
The I-number of x is defined to be an integer y, which satisfied the the conditions below:
1. y>x;
2. the sum of each digit of y(under base 10) is the multiple of 10;
3. among all integers that satisfy the two conditions above, y shouble be the minimum.
Given x, you're required to calculate the I-number of x.
 

Input
An integer T(T≤100) will exist in the first line of input, indicating the number of test cases.
The following T lines describe all the queries, each with a positive integer x. The length of x will not exceed 10 5.
 

Output
Output the I-number of x for each query.
 

Sample Input
      
      
1
202
 

Sample Output
      
      
208
 

题目大意:给你一个大整数x,叫你找出一个比x大的最小的数y,它满足条件:y的各个数位之和能被10整除
大数水题,不断模拟加1即可,不用想得太复杂。o(n)的复杂度喽
#include<cstdio>
#include<cstring>
#define maxn 100005
char a[maxn],b[maxn];
int na[maxn],nb[maxn];
void add()
{
    memset(na,0,sizeof(na));
    memset(nb,0,sizeof(nb));
    int la=strlen(a),lb=strlen(b);
    for(int i=0;a[i];i++) na[la-1-i]=a[i]-'0';
    for(int i=0;b[i];i++) nb[lb-1-i]=b[i]-'0';
    int lmax=la>lb?la:lb;
    for(int i=0;i<lmax;i++) na[i]+=nb[i],na[i+1]+=na[i]/10,na[i]%=10;
    if(na[lmax]) lmax++;
    for(int i=0;i<lmax;i++) a[lmax-i-1]=na[i]+'0';
    a[lmax]='\0';
}
bool judge()
{
    int n=0;
    for(int i=0;a[i];i++) n+=a[i]-'0';
   // printf("n=%d\n",n);
    return n%10;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        strcpy(b,"1");add();
        while(judge()) strcpy(b,"1"),add();
        printf("%s\n",a);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值