HDU1081 To The Max

                                                          To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6448    Accepted Submission(s): 3088


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
Greater New York 2001




解题思路:本题为动态规划题目,其原题型为http://blog.csdn.net/lsh670660992/article/details/9498821  ,原题是求一维数组的最大子串和,本题要求二维数组的最大子二维数组和。看似联系不大。但是,要是把数组中的相关连续列(不中断)合并到一个一维数组(模板数组),求出数组的最大子串和,就是原二维数组的一个子串和了,只要把所有的相关列枚举,求出其模板一维数组的最大子串和,再求出所有子串和中得最大值,就可以得到二维数组的最大子串和了。




#include<stdio.h>
#include<string.h>
int n,a[102];
int fmax()
{
    int sum=0;
    int max1=-0xfffffff;
    for(int i=0;i<n;i++)
    {
        sum+=a[i];
        if(sum>max1)
            max1=sum;
        if(sum<0)
            sum=0;
    }
    return max1;
}
int main()
{
    int i,j,k;
    int s[102][102];
    while(scanf("%d",&n)!=EOF)
    {
        int smax=-0xfffffff;
        for(i=0;i<n;i++)
            for(j=0;j<n;j++)
                scanf("%d",&s[i][j]);
        for(i=0;i<n;i++)
            for(j=0;j<=i;j++)
            {
                memset(a,0,sizeof(a));  //模板数组初始化
                for(int h=0;h<n;h++)
                    for(k=j;k<=i;k++)   //合并第j行到第i行(一维数组)内容
                   {
                        a[h]+=s[k][h];
                    }
                int x=fmax();    //从模板数组中找最长公共自子序列的值即可
                smax=smax>x?smax:x;
            }
        printf("%d\n",smax);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值