hdu1081To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8992    Accepted Submission(s): 4359


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15
 

Source
Greater New York 2001


最大连续子串和:

有串s,用一个临时变量t维护一个ans,若t>=0则加上s[i]可能会更好,于是有t+=s[i],
若t<0,则变成s[i]可能会更好,于是有t=s[i]
每次若大于ans,更新即可

最大子矩阵和:

有矩阵s,用一个临时数组a维护一个ans,每次a都记录s连续i行矩阵的和,
这样就可以当作最大连续子串处理,每次算出最大值更新ans,即可

#include<map>
#include<string>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<vector>
#include<iostream>
#include<algorithm>
#include<bitset>
#include<climits>
#include<list>
#include<iomanip>
#include<stack>
#include<set>
using namespace std;
int a[110],pic[110][110];
int n;
int sub()
{
	int ans=INT_MIN,t=0;
	for(int i=0;i<n;i++)
	{
		if(t>=0)
			t+=a[i];
		else
			t=a[i];
		ans=max(ans,t);
	}
	return ans;
}
int matrix()
{
	int ans=INT_MIN;
	for(int i=0;i<n;i++)
	{
		memset(a,0,sizeof(a));
		for(int j=i;j<n;j++)
		{
			for(int k=0;k<n;k++)
				a[k]+=pic[j][k];
			ans=max(ans,sub());
		}
	}
	return ans;
}
int main()
{
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				cin>>pic[i][j];
		cout<<matrix()<<endl;
	}
}


bitwise_not函数是OpenCV图像处理库中的一个函数,它将输入图像的每个像素的颜色取反。具体来说,该函数将输入图像中的每个像素的每个通道的像素值都取反,使得颜色从黑色变成白色,白色变成黑色。该函数的用法如下: bitwise_not(InputArray src, OutputArray dst) 其中,src是输入图像,dst是输出图像。函数将输入图像src的每个像素的每个通道的像素值取反,并将结果存储在输出图像dst中。 在C++中,使用OpenCV的bitwise_not函数可以实现对图像进行取反操作,即将图像中的黑色和白色颜色进行交换。例如,在以下代码片段中,我们使用bitwise_not函数对图像进行取反操作并显示结果: ```cpp #include <opencv2/opencv.hpp> int main() { cv::Mat image, image2; image = cv::imread("path/to/image.jpg"); cv::bitwise_not(image, image2); cv::imshow("result", image2); cv::waitKey(0); return 0; } ``` 这段代码读取了一张图像,然后使用bitwise_not函数对图像进行取反操作,并将结果显示在名为"result"的窗口中。请注意,这里的"path/to/image.jpg"应该替换为实际的图像文件路径。 另外,如果想要在阈值处理过程中进行取反操作,可以使用threshold函数的参数THRESH_BINARY_INV来实现,其效果与bitwise_not相同。具体用法请参考OpenCV的官方文档。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* *2* [opencv中的bitwise_not,bitwise_xor,bitwise_or,bitwise_and的使用方法与效果。](https://blog.csdn.net/zhushiq1234/article/details/51113671)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] - *3* [code_hdu.rar_ACM_The First_hdu_test case example](https://download.csdn.net/download/weixin_42651281/86645822)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_2"}}] [.reference_item style="max-width: 50%"] [ .reference_list ]
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值