F - Prime Path --BFS广搜


The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033 
1733 
3733 
3739 
3779 
8779 
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0

析:

    给出两个数进行由x到y的转换,每次只能修改一位数字,且转换后的数字必须是素数,问从x到y的转换需最小的步骤数。

思路:

    先用筛选法打出素数表,范围到100000(题目说明给出的是四位数),每次修改一位之后入队,然后枚举,直至找到y。

    注:千位数不为0。

代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
const int M=1e5+10;
int ha[M+50];
int num[M+50];
int vis[M+50];
void bfs(int x,int y)
{
    queue<int>q;
    q.push(x);
    vis[x]=1;
    while(!q.empty())
    {
        int z=q.front();
        q.pop();
        if(z==y)
            break;
        int a=z/1000;
		int b=z/100%10;
		int c=z%100/10;
		int d=z%10;
        for(int i=0; i<=9; i++)
        {
            if(!ha[a*1000+b*100+c*10+i]&&!vis[a*1000+b*100+c*10+i])
            {
                q.push(a*1000+b*100+c*10+i);
                vis[a*1000+b*100+c*10+i]=1;
                num[a*1000+b*100+c*10+i]=num[z]+1;
            }
            if(!ha[a*1000+b*100+i*10+d]&&!vis[a*1000+b*100+i*10+d])
            {
                q.push(a*1000+b*100+i*10+d);
                vis[a*1000+b*100+i*10+d]=1;
                num[a*1000+b*100+i*10+d]=num[z]+1;
            }
            if(!ha[a*1000+i*100+c*10+d]&&!vis[a*1000+i*100+c*10+d])
            {
                q.push(a*1000+i*100+c*10+d);
                vis[a*1000+i*100+c*10+d]=1;
                num[a*1000+i*100+c*10+d]=num[z]+1;
            }
            if(!ha[i*1000+b*100+c*10+d]&&!vis[i*1000+b*100+c*10+d]&&i!=0)
            {
                q.push(i*1000+b*100+c*10+d);
                vis[i*1000+b*100+c*10+d]=1;
                num[i*1000+b*100+c*10+d]=num[z]+1;
            }
        }
    }
}
int main()
{
    int t,x,y,i,j;
    for(i=2; i*i<=M; i++)   //筛选打素数表
        for(j=i*i; j<M; j+=i)
            ha[j]=1;
    cin>>t;
    while(t--)
    {
        cin>>x>>y;
        memset(num,0,sizeof(num));
        memset(vis,0,sizeof(vis));
        bfs(x,y);
        cout<<num[y]<<endl;
    }
}
参考: https://blog.csdn.net/akatsuki__itachi/article/details/76653157
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值