AcWing 1247. 后缀表达式 贪心

后缀表达式
在这里插入图片描述
输入样例

1 1
1 2 3

输出样例

4

🤠 只要有一个负号,那就可以用括号把所有的负数变成正数,只需减去 一个最小值即可

在这里插入图片描述

import java.util.*;

public class Main
{
	public static void main(String[] args)
	{
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		int m = sc.nextInt();
		int len = n + m + 1;
		int[] a = new int[len];
		int min = 0;// 存最小值在数组的下标
		int max = 0;
		for (int i = 0; i < len; i++)
		{
			a[i] = sc.nextInt();
			if (a[i] < a[min])
				min = i;
			if(a[i] > a[max])
			    max = i;
		}

		long res = 0;
//		没有减号
		if (m == 0)
		{
			for (int i = 0; i < len; i++)
				res += a[i];
		} else
		{
			res -= a[min];
			res += a[max];
			for (int i = 0; i < len; i++)
			{
				if (i == min || i == max)
					continue;
				res += Math.abs(a[i]);
			}
		}
		System.out.println(res);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值