You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3 1 5 2 6 3 7 4 2 5 3 4 4 1 1 7 3
Sample Output
5 6 3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
题意:静态区间求第k小
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#define up(i, x, y) for(int i = x; i <= y; i++)
#define down(i, x, y) for(int i = x; i >= y; i--)
#define maxn ((int)1e5 + 10)
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n, m, cnt, root[maxn], a[maxn], x, y, k;
struct node
{
int l, r, sum;
}T[maxn * 40];
vector<int> v;
int getid(int x)
{
return lower_bound(v.begin(), v.end(), x) - v.begin() + 1;
}
void update(int l, int r, int &x, int y, int pos)
{
T[++cnt] = T[y]; // 把前一棵线段树都继承过来,作为一个新的节点
T[cnt].sum++; // 因为增多该节点的儿子们会多一个权值,就是新加进来的数
x = cnt; //记录每棵在以往的基础上新增的线段树的根节点的标号,方便以后取前缀的差
//x 同时也给当前cnt节点的父亲赋了左儿子或右儿子的值。
// cout<< "l:"<< l << " r:" << r << " x:"<<x <<" y:"<<y << " pos:" << pos
// << " cnt:" << cnt << " T[x].l:" << T[x].l <<
// " T[y].l:"<<T[y].l <<" T[x].r:"<<T[x].r << " T[y].r:" << T[y].r
// << "\n";
if(l == r) return ; //到底结束,新的线段树建立完毕
int mid = (l + r) / 2;//分开
if(pos <= mid) update(l, mid, T[x].l, T[y].l, pos); //当现在需要修改的节点的位置在左边
else update(mid + 1, r, T[x].r, T[y].r, pos);
//按照需求增加需要修改的那 log(n) 个点。
}
int query(int l, int r, int x, int y, int k)// 查询的过程一直按照前缀的思想来的
{
if(l == r) return l;//找到返回
int mid = (l + r) / 2;
int sum = T[T[y].l].sum - T[T[x].l].sum; // 找左边的个数,“前缀线段树”
if(sum >= k) return query(l, mid, T[x].l, T[y].l, k);
else return query(mid + 1, r, T[x].r, T[y].r, k - sum);
}
int main()
{
scanf("%d %d", &n, &m);
for(int i = 1; i <= n; i++)
{
scanf("%d", &a[i]);
// update(1, n, root[i], root[i - 1], i);
// cout<< "i:" << i << " root[i]:" << root[i]<<'\n';
v.push_back(a[i]);
}
sort(v.begin(), v.end());
v.erase(unique(v.begin(), v.end()), v.end());
for(int i = 1; i <= n; i++)
{
update(1, n, root[i], root[i - 1], getid(a[i]));
}
for(int i = 1; i <= m; i++)
{
scanf("%d%d%d", &x, &y, &k);
printf("%d\n", v[query(1, n, root[x - 1], root[y], k) - 1]);
}
return 0;
}