杭电—1042 大数阶乘 N!

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 74385    Accepted Submission(s): 21598


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 

Author
JGShining(极光炫影)

解题思路:
依然打表,用一维数组存储就行。
AC代码:
#include<stdio.h>
#include<string.h>
#define G  36000
int a[G];
int main()
{
    int i,j,n,c,s;
    while(scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        a[0]=1;
        for(i=2;i<=n;i++)
        {
            c=0;
            for(j=0;j<G;j++)
            {
                s=a[j]*i+c;
                a[j]=s%10;
                c=s/10;
            }
        }
        for(i=G-1;i>=0;i--)
        {
            if(a[i]!=0)
            break;
        }
        for(;i>=0;i--)
        {
            printf("%d",a[i]);
        }
        printf("\n");
        
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值