杭电-1010 Tempter of the Bone(深搜)

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 106936    Accepted Submission(s): 29087


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
  
  
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
  
  
NO YES
 

Author
ZHANG, Zheng
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1016  1242  1072  1026  1240 
 

#include<stdio.h>
#include<string.h>
int vis[10][10];//用来记录这个点是否被访问过
char mat[10][10];//用来记录这个点
int ok,t,m,n;//这里的ok是用来记录判断的,如果深搜确认是可以逃出陷阱,ok被标记为1
void visit(int i,int j,int cur)//(i,j)为当前访问的坐标,cur指访问点(i,j)是第cur步,刚开始cur为0
{
    if(cur>t||ok==1) return;//如果步数超过了T,理所当然要退出啦。或者如果之前的方案确定可以逃出陷阱,理所当然要退出啦。
    else if(cur==t)  //如果当前步数为T,那么要判断当前是否到了门口
	{
        if(mat[i][j]=='D')//是的话,令ok=1
            ok=1;
        return;
    }
    else if(mat[i][j]=='.'||mat[i][j]=='S')
	{  //如果当前访问的格子合法(不要漏了“S”,不然第一次的访问将失效)
        vis[i][j]=1;  //做上标记
        if(i+1>=0&&i+1<n&&j>=0&&j<m&&vis[i+1][j]==0)  visit(i+1,j,cur+1);  //判断下一个格子是否在定义域内且是否被标记过,是,访问
        if(i-1>=0&&i-1<n&&j>=0&&j<m&&vis[i-1][j]==0)  visit(i-1,j,cur+1);
        if(i>=0&&i<n&&j+1>=0&&j+1<m&&vis[i][j+1]==0)  visit(i,j+1,cur+1);
        if(i>=0&&i<n&&j-1>=0&&j-1<m&&vis[i][j-1]==0)  visit(i,j-1,cur+1);
        vis[i][j]=0;//千万记得消除标记,这步要读者深思
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&t)!=EOF)
	{
        if(n==0||m==0||t==0)
            break;
        ok=0;//记得初始化
        for(int i=0;i<n;i++)
		{
         scanf("%s",mat[i]);  //输入图
        }
    memset(vis,0,sizeof(vis));//初始化,将vis【】【】数组全部赋值为0;
    int a,b;
    for(int i=0;i<n;i++)
	{
        for(int j=0;j<m;j++)
		{
            if(mat[i][j]=='S')
            a=i,b=j;//记录S的坐标
        }
    }
    visit(a,b,0);//从S开始访问
    if(ok==0)
        printf("NO\n");
    else if(ok==1)
        printf("YES\n");
}
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值