杭电-2196 Computer(每个点的最大路径)

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5670    Accepted Submission(s): 2834

Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 
Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 
Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 
Sample Input
  
  
5 1 1 2 1 3 1 1 1
 
Sample Output
  
  
3 2 3 4 4
Author
scnu
Recommend
lcy   |   We have carefully selected several similar problems for you:   1561  1011  3456  1520  2242 
#include <cstdio>  
#include <cstring>  
#include <queue>  
#include <algorithm>  
#define G 100000+10    
using namespace std;  
struct Edge  
{  
    int from, to, val, next;  
};  
Edge edge[G*2];  
int head[G], edgenum;  
int dist[G];  
bool vis[G];  
int N;  
int S, T;//最长路两个端点  
int d1[G], d2[G];//分别存储最长路两个端点到该点的距离  
void init()  
{  
    edgenum = 0;  
    memset(head, -1, sizeof(head));  
}  
void addEdge(int u, int v, int w)  
{  
    Edge E = {u, v, w, head[u]};  
    edge[edgenum] = E;  
    head[u] = edgenum++;  
}  
int BFS(int sx)  
{  
    queue<int> Q;  
    memset(dist, 0, sizeof(dist));  
    memset(vis, false, sizeof(vis));  
    vis[sx] = true;  
    int ans = 0;  
    int node = sx;  
    Q.push(sx);  
    while(!Q.empty())  
    {  
        int u = Q.front();  
        Q.pop();  
        for(int i = head[u]; i != -1; i = edge[i].next)  
        {  
            Edge E = edge[i];  
            if(!vis[E.to] && dist[E.to] < dist[u] + E.val)  
            {  
                 
                dist[E.to] = dist[u] + E.val;  
                if(dist[E.to] > ans)  
                {  
                    ans = dist[E.to];  
                    node = E.to;  
                }  
                Q.push(E.to); 
				vis[E.to] = true;  
            }  
        }  
    }  
    return node;  
}  
int main()  
{  
    while(scanf("%d", &N) != EOF)  
    {  
        init();  
        int a, b;  
        for(int i = 2; i <= N; i++)  
        {  
           scanf("%d%d", &a, &b);  
           addEdge(i, a, b);  
           addEdge(a, i, b);  
        }  
        S = BFS(1);//找到一个端点  
        T = BFS(S);//以找到的端点为起点 找另一个端点  
        for(int i = 1; i <= N; i++)  
            d1[i] = dist[i];//S为起点 到各点的最长路  
        BFS(T);//以另一个端点为起点  
        for(int i = 1; i <= N; i++)  
        {  
             d2[i] = dist[i];//T为起点 到各点的最长路  
            printf("%d\n", max(d1[i], d2[i]));  
        }     
    }  
    return 0;  
}  


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值