hdu 1089-hdu 1096输入输出控制练习

A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 158377    Accepted Submission(s): 84350

Problem Description
Your task is to Calculate a + b.Too easy?! Of course! I specially designed the problem for acm beginners. You must have found that some problems have the same titles with this one, yes, all these problems were designed for the same aim. 
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
 
  
1 510 20
 

Sample Output
 
 
630
 

Author
lcy
#include <stdio.h>

int main(){
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF){
		printf("%d\n",a+b);
	}
	return 0;
}


A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 118601    Accepted Submission(s): 75866


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line consists of a pair of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
 
 
21 510 20
 

Sample Output
 
 
630

#include <stdio.h>

int main(){
	int a,b,n,i;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d%d",&a,&b);
		printf("%d\n",a+b);
	}
	return 0;
}


A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 131182    Accepted Submission(s): 69477


Problem Description
Your task is to Calculate a + b.
 

Input
Input contains multiple test cases. Each test case contains a pair of integers a and b, one pair of integers per line. A test case containing 0 0 terminates the input and this test case is not to be processed.
 

Output
For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input. 
 

Sample Input
 
 
1 510 200 0
 

Sample Output
 
 
630

#include <stdio.h>

int main(){
	int a,b;
	while(1){
		scanf("%d%d",&a,&b);
		if(a==0&&b==0)break;
		printf("%d\n",a+b);
	}
	return 0;
}


A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 121985    Accepted Submission(s): 64491


Problem Description
Your task is to Calculate the sum of some integers.
 

Input
Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
 
 
4 1 2 3 45 1 2 3 4 50
 

Sample Output
 
 
1015

#include <stdio.h>

int main(){
	int a,sum=0,n,i;
	while(1){
		scanf("%d",&n);
		if(n==0)break;
		for(i=0;i<n;i++){
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		sum=0;
	}
	return 0;
}

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 90409    Accepted Submission(s): 60197


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
 
 
24 1 2 3 45 1 2 3 4 5
 

Sample Output
 
  
1015



#include <stdio.h>

int main(){
	int a,sum=0,n,i,j=0,m;
	scanf("%d",&m);
	while(j<m){
		scanf("%d",&n);
		if(n==0)break;
		for(i=0;i<n;i++){
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		sum=0;
		j++;
	}
	return 0;
}

A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84549    Accepted Submission(s): 56322


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains multiple test cases, and one case one line. Each case starts with an integer N, and then N integers follow in the same line. 
 

Output
For each test case you should output the sum of N integers in one line, and with one line of output for each line in input. 
 

Sample Input
 
 
4 1 2 3 45 1 2 3 4 5
 

Sample Output
 
 
1015


#include <stdio.h>

int main(){
	int a,sum=0,n,i;
	while(scanf("%d",&n)!=EOF){
		for(i=0;i<n;i++){
			scanf("%d",&a);
			sum+=a;
		}
		printf("%d\n",sum);
		sum=0;
	}
	return 0;
}


A+B for Input-Output Practice (VII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 83140    Accepted Submission(s): 55222


Problem Description
Your task is to Calculate a + b.
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line. 
 

Sample Input
 
 
1 510 20
 

Sample Output
 
 
630


#include <stdio.h>

int main(){
	int a,b;
	while(scanf("%d%d",&a,&b)!=EOF){
		printf("%d\n\n",a+b);
	}
	return 0;
}

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 184153    Accepted Submission(s): 55090


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
 
 
34 1 2 3 45 1 2 3 4 53 1 2 3
 

Sample Output
 
 
10156


#include <stdio.h>

int main(){
	int a,sum=0,n,i,m;
	scanf("%d",&m);
	while(m--){
		scanf("%d",&n);
		for(i=0;i<n;i++){
			scanf("%d",&a);
			sum+=a;
		}
		if(m!=0)
			printf("%d\n\n",sum);
		else
			printf("%d\n",sum);
		sum=0;
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值