【问题描述】定义Boat与Car两个类,二者都有weight属性,定义二者的一个友元函数getTotalWeight(),计算二者的重量和。

【问题描述】

定义Boat与Car两个类,二者都有weight属性,定义二者的一个友元函数getTotalWeight(),计算二者的重量和。


【输入形式】

参考的输入(数字前为提示文字):

Input boat weight:3

Input car weight:5


【输出形式】

参考的输出:

Total weight:8


【样例输入】

Input boat weight:3

Input car weight:5


【样例输出】

Total weight:8

【样例说明】
【评分标准】

#include  <iostream>
using  namespace  std;

class Car;
class Boat
{
    friend void getTotalWeight(Boat b,Car c);
public:
    void getboat();
private:
    int weight;
};

class Car
{
    friend void getTotalWeight(Boat b,Car c);
public:
    void getcar();
private:
    int weight;
};

void Boat::getboat()
{
    cout<<"Input boat weight:";
    cin>>weight;
}

void Car::getcar()
{
    cout<<"Input car weight:";
    cin>>weight;
}

void getTotalWeight(Boat b,Car c)
{
    cout<<"Total weight:"<<b.weight+c.weight;
}

int main()
{
    Boat x;
    Car y;
    x.getboat();
    y.getcar();
    getTotalWeight(x,y);
    return 0;
}

  • 1
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

那不勒斯的萤火丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值