987654321 problem

987654321 problem

Time Limit:500MS     Memory Limit:4096KB     64bit IO Format:%I64d & %I64u

Description

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321.

Input

Input contains integer number N (1<=N<=106)

Output

Write answer to the output.

Sample Input

8

Sample Output

0

个人理解,平方的后九位数只受本身的后9位数影响.当N<=8时,数不存在;当N=9时,有8种方法.当N=10时,第十位上的数有9种可能,所以共8*9=72种.N>10时,只要在72后面加N-10个"0"就可以了.具体代码如下:

#include <iostream>
using namespace std;

int main()
{
    int n,i;
    cin >> n;
    if(n < 9)
    {
         cout << "0" << endl;
    }
    else if(n == 9)
    {
         cout << "8" << endl;
    }
    else 
    {
         cout << "72" ;
         for (int i = 11; i <= n; i++)
         {
             cout << "0";
         }
         cout << endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值