4312. A + B

4312. A + B
Description

Input two integers a and b, output reverse(a)+reverse(b). reverse(a) is a new number reverse from a. For example , reverse(10)=1,reverse(123)=321.


Input

The first line contains an integer T(1<=T<=10), indicating the number of test cases.

For each case, there are two integers a, b (1<=a,b<=10000).

 
Output

One line for each case, print reverse(a)+reverse(b).


Sample Input
2
1234 4321
100 200


Sample Output
5555
3

// source code of submission 1029239, Zhongshan University Online Judge System
#include <iostream>
using namespace std;

int main()
{
	int n,a,b;
	cin >> n;
	while (n--)
	{
		int c,d;
		cin >> a >> b;
		if(a < 10)
		{
			c = a;
		}
		else if(a < 100)
		{
			c = a%10 * 10 + a/10;
		}
		else if(a < 1000)
		{
			c = a%10 * 100 + (a/10)%10 * 10 + a/100;
		}
		else if(a < 10000)
		{
			c = a%10 * 1000 + (a/10)%10*100 + (a/100)%10*10 + a/1000;
		}
		if(b < 10)
		{
			d = b;
		}
		else if(b < 100)
		{
			d = b%10 * 10 + b/10;
		}
		else if(b < 1000)
		{
			d = b%10 * 100 + (b/10)%10 * 10 + b/100;
		}
		else if(b < 10000)
		{
			d = b%10 * 1000 + (b/10)%10*100 + (b/100)%10*10 + b/1000;
		}
		cout << c+d <<endl;
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值