1962. Username Validation

1962. Username Validation

Description

 A website requests its new user to register a user name before using it. A valid (有效的) username should: (1) Contain only letters (a~z, A~Z) and digits (0~9); (2) have neither less than 6 characters nor more than 10 characters (6 <= name length <= 10); and (3) start with a letter (a~z, A~Z).
Please write a program to check whether a given string is a valid username or not.

Input

 A string in a single line, which is the user name. The string doesn't include any spaces, and contains at most 15 letters.

Output

 “Valid” or “Invalid”.

Sample Input

Tom_cat

Sample Output

Invalid

// source code of submission 964202, Zhongshan University Online Judge System
#include <iostream>
#include <string>
#include <cstring>
using namespace std;

int main()
{
    bool b = true;
    string str;
    cin >> str;
    int len = str.length();
    for ( int i = 0;i < len; i++)
    {
        if ( (str[i]>= 'A' && str[i]<= 'Z') || (str[i]>='a'&&str[i]<='z') || (str[i]>= '0' &&str[i]<= '9') )
            ;
        else b = false;
    }
    if ( (str[0]>= 'a' && str[0]<= 'z')||(str[0]>='A'&&str[0]<='Z') )
        ;
    else b = false;
    if (len < 6 || len > 10)
        b = false;
    if(b)
        cout << "Valid" << endl;
    else cout << "Invalid" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值