1960. Sum of 1 to n

1960. Sum of 1 to n

Description

 Calculate 1 + 2 + 3 + ... + n (n is an integer, and 1 <= n <= 10000). Print out the sum.

Input

The first line is an integer m, indicating the number of test cases.
Then follow m lines. The i line contains a positive number n_i.

Output

 For each number n_i, print the sum of 1 + 2 + ... + n_i in a single line.

Sample Input

2
8
100

Sample Output

36
5050

// source code of submission 964080, Zhongshan University Online Judge System
#include <iostream>
using namespace std;

int main()
{
    int m,n,sum;
    cin >> m;
    for (int i = 1; i <= m;i++)
    {
        cin >> n;
        sum = n*(1+n)/2;
        cout << sum << endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值