1154. Easy sort

1154. Easy sort

Description

You know sorting is very important. And this easy problem is:

Given you an array with N non-negative integers which are smaller than 10,000,000, you have to sort this array. Sorting means that integer with smaller value presents first.

Input

The first line of the input is a positive integer T. T is the number of the test cases followed.

The first line of each test case is a positive integer N (1<= N<= 1000) which represents the number of integers in the array. After that, N lines followed. The i-th line is the i-th integer in the array.

Output

The output of each test case should consist of N lines. The i-th line is the i-th integer of the array after sorting. No redundant spaces are needed.

Sample Input

2312311

Sample Output

1231

Problem Source

ZSUACM Team Member


// source code of submission 912268, Zhongshan University Online Judge System
#include<iostream>
using namespace std;
int main()
{
    int i,j,k;
    int T;
    int c;
    cin >> T;
    int m[1000];
    for (i = 0; i < T; i++)
    {
        cin >> c;
        for (int i = 0; i < c; i++)
        {
            cin >> m[i];
        }
        for (j = 1; j < c; j++)
        {
            int currentElement = m[j];
            for (k = j - 1; k >= 0 && m[k] > currentElement; k--)
            {
                m[k + 1] = m[k];
            }
            m[k + 1] = currentElement;
        }
        for (j = 0; j < c; j++)
        {
            cout << m[j] << endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值