hdu树形DP2196

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3972    Accepted Submission(s): 1989


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4

//这个题目我做了很久,自己也想了很久,每个点的最大距离,主要是搜索,只要这个领悟到了,做这道题应该不是很难,自己还是有很多不会的地方,我还是要多多锻炼。

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <string.h>
using namespace std;
#define maxn 10010
struct node {
      int  son;
      int  val;
      int next;
};
int max(int x,int y)
{
    if(x>y)
        return x;
    else
        return y;
}
node p[maxn];
int head[maxn*2-1];
int vis[maxn];
int dp[maxn];
int downd[maxn];
int downx[maxn];
int pos;
void add(int pa,int son,int v)
{
    p[pos].son=son;
    p[pos].val=v;
    p[pos].next=head[pa];
    head[pa]=pos++;
    return ;
}

void DFS(int fa)
{
   int  len=head[fa];
    if(len==-1){return ;}
    int w=head[fa];
    int max1=-1;
    int flag;
    while(w!=-1)
    {
        DFS(p[w].son);
        if(max1<p[w].val+downd[p[w].son])
        {
            max1=p[w].val+downd[p[w].son];
            flag=p[w].son;
        }
        w=p[w].next;
    }
    downd[fa]=max1;
    vis[fa]=flag;
   // printf("%d\n",flag);
    w=head[fa];
    max1=-1;
    while(w!=-1)
    {
        if(p[w].son!=flag&&(max1<p[w].val+downd[p[w].son]||max1<p[w].val+downx[p[w].son]))
        {
            if(max1<downd[p[w].son]+p[w].val)
              max1=downd[p[w].son]+p[w].val;
            if(max1<downx[p[w].son]+p[w].val)
                max1=downx[p[w].son]+p[w].val;
        }
       // if(p[w].son==5)
         //   printf("max1=%d\n",max1);
        w=p[w].next;
    }
    if(max1==-1)
        downx[fa]=0;
    else
        downx[fa]=max1;
}

void DFS1(int fa)
{
int     w=head[fa];
    while(w!=-1)
    {
        if(vis[fa]!=p[w].son)  dp[p[w].son]=max(downd[fa],dp[fa])+p[w].val;
        else dp[p[w].son]=max(downx[fa],dp[fa])+p[w].val;
        DFS1(p[w].son);
        w=p[w].next;
    }
    return ;
}

int main()
{
    int n;
 //  freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF)
    {
        int a,b;
        pos=0;
        memset(head,-1,sizeof(head));
        memset(dp,0,sizeof(dp));
        memset(downd,0,sizeof(downd));
        memset(downx,0,sizeof(downx));
        for(int i=2;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            add(a,i,b);
        }
        DFS(1);
        DFS1(1);
        for(int i=1;i<=n;i++)
            printf("%d\n",max(downd[i],max(downx[i],dp[i])));
    }
    return 0;
}
/*
11
1 1
1 1
2 1
2 1
3 1
6 100
6 1
3 1
9 1
9 1
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值