HDU 1541 Stars

Stars



Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output
  
  
1 2 1 1 0
 

//题意:在一个坐标系里有很多星星,每颗星星都有一个等级,每颗星星(x1,y1)的等级等于x,y坐标分别均<=这颗星星的坐标的区域内的星星数(不包括它自己)(即x<=x1&&y<=y1内的星星数),告诉你星星的坐标,让你分别求0-(N-1)个等级的星星数(即Level[0]=?,Level[1]=?......Level[N-1]=?)  表达能力比较差,凑合着看吧——!

//思路:本来直接用二维的树状数组求解就行了,但题目告诉我们 0<=X,Y<=32000,如果开个二维数组的话[32000][32000]就炸了(数组开不了这么大......),所以我们就得想办法把问题压缩成用一维的树状数组求解。

怎么压缩?可以从题目里去寻找办法。这道题很人性的一点是它给你每颗星星的坐标并不是无序的。它是根据列的顺序来给的,若列数相同,则按行序来给(Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.)。

所以我们是按列输入星星坐标的,那么把每一行的星星总数当成值add进树状数组,这样就把它压缩成一维的了。

如果这种情况怎么办?

*(1)                     *(2)
           *(3)

有人问:按行总数算的话第一行有2颗,那(3)这颗星的等级不就是2了?与实际不符

其实这种情况不用考虑,因为我们是按列顺序来输入星星的,算(3)的等级时候,(2)还没add进树状数组里,所以(3)的等级是1

感觉没怎么解释清楚——!具体看代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;

const int MAX = 32010;

int n;
int c[MAX];

int lowbit(int x)
{
	return x&(-x);
}

void add(int k, int val)
{
	while (k <= MAX)
	{
		c[k] += val;
		k += lowbit(k);
	}
}

int sum(int x)
{
	int sum = 0;
	while (x > 0)
	{
		sum += c[x];
		x -= lowbit(x);
	}
	return sum;
}

int main()
{
	int i;
	while (scanf("%d", &n) != EOF)
	{
		int x, y;
		int level[15010];
		memset(level, 0, sizeof(level));
		memset(c, 0, sizeof(c));
		for (i = 1; i <= n; i++)
		{
			scanf("%d%d", &x, &y);
			x++;//题目是x,y可以取到0,但树状数组下标是不能为0的,所以x++
			y++;//同理
			add(x, 1);
			int temp = sum(x); //把它自己也包括进去了,所以它的level是temp-1
			level[temp - 1]++;
		}
		for (i = 0; i < n; i++)
			printf("%d\n", level[i]);
	}
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值