Friend-Graph(HDU 3152)

Friend-Graph

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1752    Accepted Submission(s): 870


Problem Description
It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.
In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.
A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.(T<=15)
The first line od each case should contain one integers n, representing the number of people of the team.( n3000 )

Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.
 

Output
Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.
 

Sample Input
  
  
1 4 1 1 0 0 0 1
 

Sample Output
  
  
Great Team!
 
//题目:有3个人以上互相认识或互相不认识就是Bad Team,不然就是Good Team。给定一张图,求Good Team/Bad Team

//思路:一开始用最大团做,不出意外的TLE了。后来发现暴力搜整张图中是否存在节点个数为3的环即可,图正反各求一遍。PS:只能用一个二维数组,否则会MLE。

#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>

using namespace std;

const short MAX=3005;

int n;
bool map[MAX][MAX];
bool vis[MAX];

//搜是否存在大小为3的环
bool judge()
{
    memset(vis,false,sizeof(vis));
    int i,j;
    queue<int>q;
    q.push(1);
    vis[1]=true;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        for(i=1;i<n;i++)
        {
            for(j=i+1;j<=n;j++)
            {
                if(map[i][j]==true&&map[now][i]==true&&map[now][j]==true)
                {
                    return false;
                }
            }
            if(map[i][j]==true&&vis[i]==false)
            {
                vis[i]=true;
                q.push(i);
            }
        }
    }
    return true;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                int num;
                scanf("%d",&num);
                if(num==1)
                    map[i][j]=map[j][i]=true;
                else
                    map[i][j]=map[j][i]=false;
            }
        }
        if(judge()==false)
        {
            printf("Bad Team!\n");
            continue;
        }
        //建反图
        for(int i=1;i<n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                if(map[i][j]==true)
                {
                    map[i][j]=map[j][i]=false;
                }
                else
                {
                    map[i][j]=map[j][i]=true;
                }
            }
        }
        if(judge()==false)
            printf("Bad Team!\n");
        else
            printf("Great Team!\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值