[PAT] C++ 1142. Maximal Clique (25)

题目

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line “Yes” if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print “Not Maximal”; or if it is not a clique at all, print “Not a Clique”.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

解析

这道题是给定一个无向图,然后给定一个顶点集合,如果这个顶点集合内任意两个顶点都是直接连接,且若再增加图中任意一个其他顶点进来都不满足条件,则为Clique,输出Yes,若满足顶点集合内任意两个顶点都是直接连接,且可增加图中其他某个顶点进来形成新的集合也满足条件,则为Not Maximal,如果顶点集合中不满足任意两个顶点直接连接,则输出Not a Clique

代码

#include <iostream>
#include <vector>
#include <algorithm>
#include <string>
#include <map>
using namespace std;

int findRes(vector<vector<int> > &graph,vector<int> &nums){
    int res=-1;
    int len=graph.size();
    vector<bool> isView(len,false);
    int lenm=nums.size();
    for(int i=0;i<lenm;i++){
        isView[nums[i]]=true;
        for(int j=i+1;j<lenm;j++){
            if(graph[nums[i]][nums[j]]!=1){
                return -1;
            }
        }
    }
    res=0;
    for(int i=1;i<len;i++){
        if(isView[i]==true) continue;
        int j=0;
        for(j=0;j<lenm;j++){
            if(graph[i][nums[j]]!=1) break;
        }
        if(j==lenm) return 0;
    }
    return 1;
}

int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    vector<vector<int> > graph(n+1,vector<int>(n+1,0));
    for(int i=0;i<m;i++){
        int n1,n2;
        scanf("%d%d",&n1,&n2);
        graph[n1][n2]=1;
        graph[n2][n1]=1;
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++){
        int k;
        scanf("%d",&k);
        vector<int> nums(k);
        for(int j=0;j<k;j++){
            scanf("%d",&nums[j]);
        }
        int res=findRes(graph,nums);
        if(res==0) printf("Not Maximal\n");
        else if(res==1) printf("Yes\n");
        else printf("Not a Clique\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值