Counterfeit Dollar

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 41569 Accepted: 13241

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light.
#include <iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<cmath>
using namespace std;
int a[128];        //记录每个字母出现的次数;
int flag[128];     //标记好的硬币;
char s[20],y[20],u[20];  // 输入;
int main()
{
   int t,i,j,len;
   while(~scanf("%d",&t))
   {
       while(t--)
       {
           memset(flag,0,sizeof(flag));
           memset(a,0,sizeof(a));
           for(i=0;i<7;i+=3)
           {
               scanf("%s%s%s",s,y,u);
               len=strlen(s);
               if(strcmp(u,"even")==0)
               {
                   for(j=0;j<len;j++)
                   {
                       flag[s[j]]=1;                //出现even标记好的硬币;
                       flag[y[j]]=1;
                   }
               }
               else if(strcmp(u,"up")==0)
               {
                   for(j=0;j<len;j++)
                   {
                       a[s[j]]++;                              // 出现UP,左加右减;(怀疑其中任意一个都重或轻);
                   }
                   for(j=0;j<len;j++)
                   {
                       a[y[j]]--;
                   }
               }
               else
               {
                   for(j=0;j<len;j++)
                   {
                       a[s[j]]--;
                   }
                   for(j=0;j<len;j++)                             //同理;
                   {
                       a[y[j]]++;
                   }
               }
           }
           int pos,sum=0;
           int c;
           for(i=64;i<128;i++)
           {                                                            / 找出被怀疑中,可能性最大的,负为轻,正为重;
               if(!flag[i]&&sum<abs(a[i]))
               {
                   sum=abs(a[i]);
                   pos=i;
                   c=a[i];
               }
           }
           if(c>0)
            printf("%c is the counterfeit coin and it is heavy.\n",pos);
           else
            printf("%c is the counterfeit coin and it is light.\n",pos);
       }
   }
    return 0;
}
注:一开始想的太复杂了;参考李标的想法;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值