Number Sequence

Number Sequence

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

A number sequence is defined as follows: 

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7. 

Given A, B, and n, you are to calculate the value of f(n).

输入

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

输出

For each test case, print the value of f(n) on a single line.

示例输入

1 1 3
1 2 10
0 0 0

示例输出

2
5

提示

知识扩展:本类算法在数字医疗、移动证券、手机彩票、益智类解谜类游戏软件中会经常采用。

来源

 

示例程序

矩阵快速幂!唉,事后听了大神的一般数很大又取莫之类的,都是有些思维题;
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<cmath>
using namespace std;
void solve(int a,int b,int n)
{
	int ans_1=1,ans_2=1,c=1,d=0;
	int tmp,w,x,y,z;
	n-=2;
	while(n)
	{
		if(n&1)
		{
			tmp=ans_1;
			ans_1=(ans_1*a%7+ans_2*b%7)%7;
			ans_2=tmp*c+ans_2*d;
		}
		w=a;x=b;y=c;z=d;
		a=(w*w+y*x)%7;
		c=(w*y+y*z)%7;
		b=(w*x+x*z)%7;
		d=(x*y+z*z)%7;
			n>>=1;
	}
	printf("%d\n",ans_1);
}
int main()
{
     int a,b,n;
     while(~scanf("%d%d%d",&a,&b,&n)&&(a||b||n))
	 {
	 	if(n<=2)
			{
				printf("1\n");
		continue;
			}
			solve(a,b,n);
	 }
    return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值