Bridge

Bridge
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3602 Accepted: 1262 Special Judge

Description

n people wish to cross a bridge at night. A group of at most two people may cross at any time, and each group must have a flashlight. Only one flashlight is available among the n people, so some sort of shuttle arrangement must be arranged in order to return the flashlight so that more people may cross. 
Each person has a different crossing speed; the speed of a group is determined by the speed of the slower member. Your job is to determine a strategy that gets all n people across the bridge in the minimum time. 

Input

The first line of input contains n, followed by n lines giving the crossing times for each of the people. There are not more than 1000 people and nobody takes more than 100 seconds to cross the bridge.

Output

The first line of output must contain the total number of seconds required for all n people to cross the bridge. The following lines give a strategy for achieving this time. Each line contains either one or two integers, indicating which person or people form the next group to cross. (Each person is indicated by the crossing time specified in the input. Although many people may have the same crossing time the ambiguity is of no consequence.) Note that the crossings alternate directions, as it is necessary to return the flashlight so that more may cross. If more than one strategy yields the minimal time, any one will do.

Sample Input

4
1
2
5
10

Sample Output

17
1 2
1
5 10
2
1 2

Source

由于一次过桥最多两人且手电筒需要往返传递,因此以两个成员过桥为一个分析单位,计算过桥时间。
假设 A是最快的人,B是次快的人;

         a是最慢的人,b是次慢的人;

有两种过桥方案:

一:最快成员A传递手电筒帮助最慢的a,b,过桥;

时间为:time_1=2*A+a+b;

二: 最快成员A和次快成员B传递手电筒帮助最慢的a和b过桥;

时间为:time_2= 2*b+A+a;

如果(time_1>time_2)选择方案二;‘

否则选择方案一;

最后剩下(n==2||n==3)

if(n==2)

累计时间+=B;

否则

累计时间+=a+A+B;

#include <iostream>
#include<algorithm>
#include<cmath>
#include<cstdio>
using namespace std;
int a[1010];
int main()
{
     int n;
     while(~scanf("%d",&n))
     {
         for(int i=1;i<=n;i++)
         {
             scanf("%d",&a[i]);
         }
         if(n==1)
         {
             printf("%d\n%d\n",a[1],a[1]);
             continue;
         } int m=n;
         sort(a+1,a+n+1);
         int sum=0;

         while(n>3)
         {
             if(a[1]+a[n-1]>2*a[2])
             {
                 sum+=a[1]+2*a[2]+a[n];
             }
             else
             {
                 sum+=2*a[1]+a[n]+a[n-1];
             }
             n-=2;
         }
         if(n==2)
            sum+=a[2];
         else
            sum+=a[1]+a[2]+a[3];
         printf("%d\n",sum);
         n=m;
         while(n>3)
         {
             if(2*a[2]<a[1]+a[n-1])
             {
                 printf("%d %d\n%d\n%d %d\n%d\n",a[1],a[2],a[1],a[n-1],a[n],a[2]);
             }
             else
             {
                 printf("%d %d\n%d\n%d %d\n%d\n",a[1],a[n],a[1],a[1],a[n-1],a[1]);
             }
             n-=2;
         }
         if(n==2)
         {
             printf("%d %d\n",a[1],a[2]);
         }
         else
         {
             printf("%d %d\n%d\n%d %d\n",a[1],a[2],a[1],a[1],a[3]);
         }
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值