Catch That Cow

8 篇文章 0 订阅
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 60573 Accepted: 18904

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
struct node
{
    int x;
    int step;
};
int m,n;
bool flag[200010];
int  bfs()
{
    memset(flag,0,sizeof(flag));
    node now,tmp;
    now.x=n;
    now.step=0;
    flag[n]=1;
    queue<node>Q;
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if(now.x==m)
        {
            return now.step;
        }
        for(int i=0; i<3; i++)
        {
            tmp=now;
            if(i==0)
            {
                if(tmp.x>0&&!flag[tmp.x-1])
                {
                    tmp.x--;
                    tmp.step++;
                    flag[tmp.x]=1;
                    Q.push(tmp);
                }
            }
            if(i==1)
            {
                if(!flag[tmp.x+1])
                {
                    tmp.x++;
                    tmp.step++;
                    flag[tmp.x]=1;
                    Q.push(tmp);
                }
            }
            else if(i==2)
            {
                if(tmp.x<100010&&!flag[tmp.x*2])
                {
                    tmp.x*=2;
                    tmp.step++;
                    flag[tmp.x]=1;
                    Q.push(tmp);
                }
            }
        }

    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        printf("%d\n",bfs());
    }
    return 0;
}

可+1,-1,*2;BFS模板题;
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值