Find The Multiple

8 篇文章 0 订阅
0ms,飘过;这道题一开始用DFS做的TLE;想想2^200肯定超啊;后来像题中说枚举一个即可,说明有多个,于是缩小,一直网下缩,所成了WA,完了,得换路子,用BFS居然说超内存(MLE);
可能是分的情况太多而且存在大量的重复数据,      算,就200个数,打出来;然后过了!;


Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21769 Accepted: 8947 Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

Source

Dhaka 2002
BFS(MLE)的代码;


#include <iostream>
#include<queue>
#include<cstdio>
using namespace std;
struct node
{
    int c[30];
    int cnt;
    int yu;
};
queue<node>Q;
void BFS(int n)
{
    int g;
    node now ,tmp;
    now.c[0]=1;
    now.cnt=0;
    now.yu=0;
    while(!Q.empty())
        Q.pop();
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        g=(now.c[now.cnt]+now.yu*10)%n;
        if(g==0)
        {
            printf("\"");
            for(int i=0; i<=now.cnt; i++)
            {
                printf("%d",now.c[i]);
            }
            printf("\",");
            return;
        }
        else
        {
            now.yu=g;
        }
        if(now.cnt>40)
            continue;
        for(int i=0; i<2; i++)
        {
            tmp=now;
            if(i==0)
            {
                tmp.cnt++;
                tmp.c[tmp.cnt]=0;
                Q.push(tmp);
            }
            else
            {
                tmp.cnt++;
                tmp.c[tmp.cnt]=1;
                Q.push(tmp);
            }
        }
    }
}
int main()
{
     freopen("out.txt","w",stdout);


        for(int i=1;i<=202;i++)
        BFS(i);

    return 0;
}
有上述打表AC的代码;





#include <iostream>
#include<cstring>
using namespace std; 
char  s[220][30]={"0","1","10","111","100","10","1110","1001","1000","111111111","10","11","11100","1001","10010","1110","10000","11101","1111111110","11001","100","10101","110","110101","111000","100","10010","1101111111","100100","1101101","1110","111011","100000","111111","111010","10010","11111111100","111","110010","10101","1000","11111","101010","1101101","1100","1111111110","1101010","10011","1110000","1100001","100","100011","100100","100011","11011111110","110","1001000","11001","11011010","11011111","11100","100101","1110110","1111011111","1000000","10010","1111110","1101011","1110100","10000101","10010","10011","111111111000","10001","1110","11100","1100100","1001","101010","10010011","10000","1111111101","111110","101011","1010100","111010","11011010","11010111","11000","11010101","1111111110","1001","11010100","10000011","100110","110010","11100000","11100001","11000010","111111111111111111","100","101","1000110","11100001","1001000","101010","1000110","100010011","110111111100","1001010111","110","111","10010000","1011011","110010","1101010","110110100","10101111111","110111110","100111011","111000","11011","1001010","10001100111","11101100","1000","11110111110","11010011","10000000","100100001","10010","101001","11111100","11101111","11010110","11011111110","11101000","10001","100001010","110110101","100100","10011","100110","1001","1111111110000","11011010","100010","1100001","11100","110111","11100","1110001","11001000","10111110111","10010","1110110","1010100","10101101011","100100110","100011","100000","11101111","11111111010","1010111","1111100","1111110","1010110","11111011","10101000","10111101","111010","1111011111","110110100","1011001101","110101110","100100","110000","100101111","110101010","11010111","11111111100","1001111","10010","100101","110101000","1110","100000110","1001011","1001100","1010111010111","110010","11101111","111000000","11001","111000010","101010","110000100","1101000101","1111111111111111110","111000011","1000","10010001","1010",};
int main()
{
    int n;
    while(cin>>n,n)
    {
        cout<<s[n]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值