HDU5429----A problem of sorting

6 篇文章 0 订阅

A problem of sorting

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 565    Accepted Submission(s): 257


提示:注意名字中包括空格,
Problem Description
There are many people's name and birth in a list.Your task is to print the name from young to old.(There is no pair of two has the same age.)


 

Input
First line contains a single integer T100 which denotes the number of test cases.

For each test case, there is an positive integer n(1n100) which denotes the number of people,and next n lines,each line has a name and a birth's year(1900-2015) separated by one space.

The length of name is positive and not larger than 100 .Notice name only contain letter(s),digit(s) and space(s).
 

Output
For each case, output n lines.
 

Sample Input
  
  
2 1 FancyCoder 1996 2 FancyCoder 1996 xyz111 1997
 

Sample Output
  
  
FancyCoder xyz111 FancyCoder
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5431  5429  5427  5426  5425

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<vector>
#include<climits>
#include<iomanip>
#define LL long long
#define uing unsigned int
#define uLL unsigned LL
using namespace std;
const int INF =0x3f3f3f3f;
const double PI = acos(-1.0);
const double esp=1e-6;
struct node
{
    int year;
    char s[120];

}que[1010];
bool cmp(node x,node y)
{
    return x.year>y.year;
}
int main()
{
    int t,n,len;
    char c[142];
    scanf("%d",&t);
    while(t--)
    {
         memset(que,0,sizeof(que));
        scanf("%d%*c",&n);
        for(int i=0;i<n;i++)
        {
            gets(c);
            len=strlen(c);
            for(int j=len-4;j<len;j++)
            {
                que[i].year=que[i].year*10+c[j]-'0';
            }
            for(int j=0;j<len-5;j++)
            {
                que[i].s[j]=c[j];
            }
            que[i].s[len-5]='\0';
        }
        sort(que,que+n,cmp);
        for(int i=0;i<n;i++)
            printf("%s\n",que[i].s);
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值