An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N(≤) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2 lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目大意:
根据所给的对树的操作,给出树的后序遍历
题目分析:
push的顺序即是树的前序遍历,然后再结合pop可以得出该树的中序遍历,利用push和pop的操作顺序,来重新构建树,再利用递归对树进行后续遍历。
当push一个节点时,若该push操作的前一个操作是push操作,则该节点作为parent节点的左儿子;若该push操作的前一个操作为pop操作,则该节点作为parent节点的右儿子。
代码:
#include<stdio.h>
#include<stdlib.h>
#define ElementType int
#define STR_LEN 5
typedef struct TreeNode *Tree;
struct TreeNode{
ElementType Element;
Tree Left;
Tree Right;
};
struct Stack{
Tree location;
}stack[100];
int top=0;
ElementType values[20];
int num=0;
void Push(Tree temp)
{
stack[top].location=temp;
top++;
}
Tree Pop()
{
if(top)
{
Tree node=stack[--top].location;
return node;
}
else
return NULL;
}
Tree BuildTree()
{
char str[STR_LEN];
int N,i,num;
int poped=0,findRoot=0;
Tree parent=NULL,Root=NULL;
scanf("%d",&N);
for(i=0;i<2*N;i++)
{
scanf("%s",&str);
if(strcmp(str,"Push")==0)
{
scanf("%d",&num);
Tree node=(Tree)malloc(sizeof(struct TreeNode));
node->Element=num;
node->Left=NULL;
node->Right=NULL;
//if(!parent&&!poped)
if(parent&&!poped) //父节点不为空,但前一个操作为push,则新输入节点作为父节点的左孩子
{
parent->Left=node;
parent=node;
}
else if(parent&&poped) //前一个操作为pop,则新输入的节点作为父节点的右节点
{
parent->Right=node;
parent=node;
}
else //父节点为空,说明还未添加节点到树中
{
Root=node;
parent=node;
}
Push(parent);
poped=0;
}
else
{
parent=Pop();
poped=1;
}
}
return Root;
}
void PostOrder(Tree T)
{
Tree tn = T;
if(tn)
{
PostOrder(tn->Left);
PostOrder(tn->Right);
values[num++] = tn->Element; //将后序遍历出的节点值存入数组便于格式化打印
}
}
int main()
{
Tree T=BuildTree();
Tree middle;
PostOrder(T);
int i;
for (i = 0; i < num-1; i++)
printf("%d ", values[i]);
printf("%d\n", values[num-1]);
return 0;
}