POJ2125:Destroying The Graph


Destroying The Graph
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4718   Accepted: 1436   Special Judge

Description

Alice and Bob play the following game. First, Alice draws some directed graph with N vertices and M arcs. After that Bob tries to destroy it. In a move he may take any vertex of the graph and remove either all arcs incoming into this vertex, or all arcs outgoing from this vertex. 
Alice assigns two costs to each vertex: Wi + and Wi -. If Bob removes all arcs incoming into the i-th vertex he pays Wi + dollars to Alice, and if he removes outgoing arcs he pays Wi - dollars. 
Find out what minimal sum Bob needs to remove all arcs from the graph.

Input

Input file describes the graph Alice has drawn. The first line of the input file contains N and M (1 <= N <= 100, 1 <= M <= 5000). The second line contains N integer numbers specifying Wi +. The third line defines Wi - in a similar way. All costs are positive and do not exceed 10 6 . Each of the following M lines contains two integers describing the corresponding arc of the graph. Graph may contain loops and parallel arcs.

Output

On the first line of the output file print W --- the minimal sum Bob must have to remove all arcs from the graph. On the second line print K --- the number of moves Bob needs to do it. After that print K lines that describe Bob's moves. Each line must first contain the number of the vertex and then '+' or '-' character, separated by one space. Character '+' means that Bob removes all arcs incoming into the specified vertex and '-' that Bob removes all arcs outgoing from the specified vertex.

Sample Input

3 6
1 2 3
4 2 1
1 2
1 1
3 2
1 2
3 1
2 3

Sample Output

5
3
1 +
2 -
2 +

Source

Northeastern Europe 2003, Northern Subregion



一道典型的最小点权覆盖问题,SAP速度很好看,之后需要搜索一下用过的点,输出即可。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#define N 10010
#define M 20010
#define inf 1 << 30
#define eps 1 << 29
using  namespace std;

int mark[N];
int cnt, n, m, s, t;
int head[N];
int NN;

struct edge
{
     int v, next, w;
} edge[M];

void addedge( int u,  int v,  int w)
{
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].next = head[u];
    head[u] = cnt++;
    edge[cnt].v = u;
    edge[cnt].w = 0;
    edge[cnt].next = head[v];
    head[v] = cnt++;
}

int sap()
{
     int pre[N], cur[N], dis[N], gap[N];
     int flow = 0, aug = inf, u;
     bool flag;
     for ( int i = 1; i <= NN; ++i)
    {
        cur[i] = head[i];
        gap[i] = dis[i] = 0;
    }
    gap[s] = NN;
    u = pre[s] = s;
     while (dis[s] < NN)
    {
        flag = 0;
         for ( int &j = cur[u]; j != -1; j = edge[j].next)
        {
             int v = edge[j].v;
             if (edge[j].w > 0 && dis[u] == dis[v] + 1)
            {
                flag = 1;
                 if (edge[j].w < aug) aug = edge[j].w;
                pre[v] = u;
                u = v;
                 if (u == t)
                {
                    flow += aug;
                     while (u != s)
                    {
                        u = pre[u];
                        edge[cur[u]].w -= aug;
                        edge[cur[u] ^ 1].w += aug;
                    }
                    aug = inf;
                }
                 break;
            }
        }
         if (flag)
             continue;
         int mindis = NN;
         for ( int j = head[u]; j != -1; j = edge[j].next)
        {
             int v = edge[j].v;
             if (edge[j].w > 0 && dis[v] < mindis)
            {
                mindis = dis[v];
                cur[u] = j;
            }
        }
         if ((--gap[dis[u]]) == 0)
             break;
        gap[dis[u] = mindis + 1]++;
        u = pre[u];
    }
     return flow;
}

void init()
{
    cnt = 0;
    memset(head, -1,  sizeof(head));
    memset(mark, 0,  sizeof(mark));
}

void dfs( int x)      //不同于单纯的SAP,加入了一个搜素点集元素的函数,通过head数组的记录信息搜索。
{
    mark[x] = 1;
     for ( int i = head[x]; i; i = edge[i].next)
    {
         if (edge[i].w > 0 && !mark[edge[i].v]) dfs(edge[i].v);
    }
}

int main()
{
     while (scanf("%d%d", &n, &m) != EOF)
    {
        init();
         int wp[101], wm[101], w, len = 1, ans[105];
        s = 0;
        t = 2 * n + 1;
        NN = 2 * n + 2;
         for ( int i = 1; i <= n; ++i)
        {
            scanf("%d", &wp[i]);
            addedge(i + n, t, wp[i]);
        }
         for ( int i = 1; i <= n; ++i)
        {
            scanf("%d", &wm[i]);
            addedge(s, i, wm[i]);
        }
         for ( int i = 1; i <= m; ++i)
        {
             int x, y;
            scanf("%d%d", &x, &y);
            addedge(x, y + n, inf);
        };
        w = sap();
        dfs(s);
         for ( int i = 1; i <= n; ++i)
        {
             if (!mark[i]) ans[len++] = i;
             if (mark[i + n]) ans[len++] = i + n;
        }
        len--;
        printf("%d\n%d\n", w, len);
         for ( int i = 1; i <= len; ++i)
        {
             if (ans[i] <=n) printf("%d -\n", ans[i]);
             else printf("%d +\n", ans[i] - n);
        }
    }
     return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值