2011 ACM/ICPC 北京赛区现场赛解题:Qin Shi Huang's National Road System

Qin Shi Huang's National Road System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 216    Accepted Submission(s): 105


Problem Description
During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese.

Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system:
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang.
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads.
Would you help Qin Shi Huang?
A city can be considered as a point, and a road can be considered as a line segment connecting two points.
 

Input
The first line contains an integer t meaning that there are t test cases(t <= 10).
For each test case:
The first line is an integer n meaning that there are n cities(2 < n <= 1000).
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city.
It is guaranteed that each city has a distinct location.
 

Output
For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.
 

Sample Input
  
  
2 4 1 1 20 1 2 30 200 2 80 200 1 100 3 1 1 20 1 2 30 2 2 40
 

Sample Output
  
  
65.00 70.00
 

Source
 

Recommend
lcy
 


首先求一次最小生成树,之后枚举所有的边为魔法路,对于魔法路有两种情况:
1.路在最小生成树上,那么A就是两端城市人口,B就是最小生成树-枚举的边。
2.路不在树上,那么A依旧是两端城市人口,而这条路的加入必然导致环的出现,那么B就是最小生成树减去环上最长路了。

其中,环上最长路也就是树上两点间的最长路,在prim做最小生成树时可以求出(思路类似与此小生成树的思想)。
代码:
#include <cstdio>
#include <cstring>
#include <queue>
#include <vector>
#include <cmath>
#define inf 1 << 30
#define MAXN 1010
using namespace std;

struct Edge
{
    int u, v, next;
    double s;
    bool flag;
} edge[2 * MAXN * MAXN];

int head[MAXN];
int pos;

void insert(int x, int y, double s)
{
    edge[pos].u = x;
    edge[pos].v = y;
    edge[pos].s = s;
    edge[pos].flag = false;
    edge[pos].next = head[x];
    head[x] = pos++;
}

struct Node
{
    int id;
    double dd;
    bool operator < (Node a) const
    {
        return a.dd < dd;
    }
} node;

int n, m;

priority_queue <Node> Q;

double map[MAXN][MAXN];
bool vis[MAXN];
double dis[MAXN];

double prim()
{
    double sum = 0.0;
    while (!Q.empty())
        Q.pop();
    int ee = 1;
    int now, v;
    memset(vis, false, sizeof(vis));
    dis[1] = 0.0;
    for (int i = 2; i <= n; ++i)
        dis[i] = inf;
    for (int i = head[1]; i != -1; i = edge[i].next)
    {
        node.id = i;
        node.dd = edge[i].s;
        Q.push(node);
        v = edge[i].v;
        dis[v] = edge[i].s;
    }
    vis[1] =true;
    while (!Q.empty())
    {
        Node pp = Q.top();
        Q.pop();
        int id = pp.id;
        v = edge[id].v;
        if (vis[v])
            continue;
        now = edge[id].u;
        edge[id].flag = true;
        edge[id ^ 1].flag = true;
        map[now][v] = map[v][now] = edge[id].s;
        sum += edge[id].s;
        for (int j = 1; j <= n; ++j)
        {
            if (!vis[j])
                continue;
            if (map[j][now] < edge[id].s)
                map[j][v] = map[v][j] = edge[id].s;
            else
                map[j][v] = map[v][j] = map[j][now];
        }
        vis[v] = true;
        now = v;
        ee++;
        for (int i = head[now]; i != -1; i = edge[i].next)
        {
            v = edge[i].v;
            if (edge[i].s < dis[v])
            {
                dis[v] = edge[i].s;
                node.id = i;
                node.dd = edge[i].s;
                Q.push(node);
            }
        }
    }
    return sum;
}

int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        memset(head, -1, sizeof(head));
        pos = 0;
        scanf("%d", &n);
        int x[MAXN], y[MAXN], p[MAXN];
        for (int i = 1; i <= n; ++i)
            scanf("%d%d%d", &x[i], &y[i], &p[i]);
        for (int i = 1; i < n; ++i)
            for (int j = i + 1; j <= n; ++j)
            {
                double dis;
                dis = sqrt((x[i] - x[j]) * (x[i] - x[j]) + (y[i] - y[j]) * (y[i] - y[j]));
                insert(i, j, dis);
                insert(j, i, dis);
            }
        double ans = 0.0;
        int A = 0;
        double B = 0;
        B = prim();
        for (int i = 0; i < pos; i += 2)
        {
            int a, b;
            double c;
            if (edge[i].flag)
            {
                a = edge[i].u;
                b = edge[i].v;
                c = edge[i].s;
                if ((p[a] + p[b]) / (B - c) > ans) ans = (p[a] + p[b]) / (B - c);
            }
            else
            {
                a = edge[i].u;
                b = edge[i].v;
                c = edge[i].s;
                if ((p[a] + p[b]) / (B - map[a][b]) > ans) ans = (p[a] + p[b]) / (B - map[a][b]);
            }
        }
        printf("%.2lf\n", ans);
    }
    return 0;
}

 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值