2013成都站F题||hdu4786 并查集 生成树

http://acm.hdu.edu.cn/showproblem.php?pid=4786

Problem Description
  Coach Pang is interested in Fibonacci numbers while Uncle Yang wants him to do some research on Spanning Tree. So Coach Pang decides to solve the following problem:
  Consider a bidirectional graph G with N vertices and M edges. All edges are painted into either white or black. Can we find a Spanning Tree with some positive Fibonacci number of white edges?
(Fibonacci number is defined as 1, 2, 3, 5, 8, ... )
 

Input
  The first line of the input contains an integer T, the number of test cases.
  For each test case, the first line contains two integers N(1 <= N <= 10 5) and M(0 <= M <= 10 5).
  Then M lines follow, each contains three integers u, v (1 <= u,v <= N, u<> v) and c (0 <= c <= 1), indicating an edge between u and v with a color c (1 for white and 0 for black).
 

Output
  For each test case, output a line “Case #x: s”. x is the case number and s is either “Yes” or “No” (without quotes) representing the answer to the problem.
 

Sample Input
  
  
2 4 4 1 2 1 2 3 1 3 4 1 1 4 0 5 6 1 2 1 1 3 1 1 4 1 1 5 1 3 5 1 4 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
题目大意:给定一个图,确定是一个连通图。每条边有一定的颜色,黑或白。求是否有这样一棵生成树保证所有的树边的总数为一个Fibonacci数。

解题思路:

               按边的颜色排序两次,一次黑边优先,利用并查集构造一个生成树,此时是所有方法中白边最少的情况,x。而后白边优先,得出的是白边最多的情况,y。找找x,y二者之间是否包括一个Fibonacci数即可。

#include <string.h>
#include <stdio.h>
#include <iostream>
#include <algorithm>
//#define debug
using namespace std;
struct note
{
    int u,v,c;
} edge[100005];
int n,m,fa[100005],num;
bool cmp1(note a,note b)
{
    return a.c<b.c;
}
bool cmp2(note a,note b)
{
    return a.c>b.c;
}
void initset()
{
    for(int i=0; i<=n; i++)
        fa[i]=i;
}
int find(int x)
{
    if(x==fa[x])
        return x;
    return fa[x]=find(fa[x]);
}
int un(int x,int y)
{
    x=find(x);
    y=find(y);
    if(x!=y)
    {
        fa[y]=x;
        num++;
        return 1;
    }
    return 0;
}
int a[1005];
void fib()
{
    a[0]=1;
    a[1]=1;
    for(int i=2; i<30; i++)
        a[i]=a[i-1]+a[i-2];
#ifdef debug
    printf("%d\n",a[29]);
#endif // debug
}
int main()
{
    int T,tt=0;
    scanf("%d",&T);
    fib();
    while(T--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<m; i++)
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].c);
        initset();
        sort(edge,edge+m,cmp1);
        int cnt1;
        num=0;
        int count=0;
        for(int i=0; i<m; i++)
        {
            if(un(edge[i].u,edge[i].v))
                count+=edge[i].c;
            if(num==n-1)
            {
                cnt1=count;
                break;
            }
        }
        initset();
        sort(edge,edge+m,cmp2);
        int cnt2;
        num=0;
        count=0;
        for(int i=0; i<m; i++)
        {
            if(un(edge[i].u,edge[i].v))
                count+=edge[i].c;
            if(num==n-1)
            {
                cnt2=count;
                break;
            }
        }
        int flag=0;
        for(int i=0; i<29; i++)
            if(cnt1==a[i]||cnt2==a[i])
            {
                printf("Case #%d: Yes\n",++tt);
                flag=1;
                break;
            }
        if(flag)
            continue;
        int x=upper_bound(a,a+29,cnt1)-a;
        int y=upper_bound(a,a+29,cnt2)-a;
        if(x==y)
            printf("Case #%d: No\n",++tt);
        else
            printf("Case #%d: Yes\n",++tt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值