hdu4328 最大子矩阵问题O(n*m)扫描思想

http://acm.hdu.edu.cn/showproblem.php?pid=4328



Problem Description
Mark bought a huge cake, because his friend ray_sun’s birthday is coming. Mark is worried about how to divide the cake since it’s so huge and ray_sun is so strange. Ray_sun is a nut, you can never imagine how strange he was, is, and going to be. He does not eat rice, moves like a cat, sleeps during work and plays games when the rest of the world are sleeping……It is not a surprise when he has some special requirements for the cake. A considering guy as Mark is, he will never let ray_sun down. However, he does have trouble fulfilling ray_sun’s wish this time; could you please give him a hand by solving the following problem for him?
  The cake can be divided into n*m blocks. Each block is colored either in blue or red. Ray_sun will only eat a piece (consisting of several blocks) with special shape and color. First, the shape of the piece should be a rectangle. Second, the color of blocks in the piece should be the same or red-and-blue crisscross. The so called ‘red-and-blue crisscross’ is demonstrated in the following picture. Could you please help Mark to find out the piece with maximum perimeter that satisfies ray_sun’s requirements?

 

Input
The first line contains a single integer T (T <= 20), the number of test cases.
  For each case, there are two given integers, n, m, (1 <= n, m <= 1000) denoting the dimension of the cake. Following the two integers, there is a n*m matrix where character B stands for blue, R red.
 

Output
For each test case, output the cased number in a format stated below, followed by the maximum perimeter you can find.
 

Sample Input
  
  
2 1 1 B 3 3 BBR RBB BBB
 

Sample Output
  
  
Case #1: 4 Case #2: 8
/**
hdu4328 最大子矩阵问题O(n*m)
题目大意:给定一个n*m的棋盘有红黑两色,让截取一个周长最大矩形,该矩形要么全是黑色,要么全是红色,要么黑色和红色交替
           见题目附图。
解题思路:如果遍历每一个矩阵是不可能的,时间O(n*n*n),因此我们采用扫描的方法(白书P51)。对于交替的矩形我们把(i+j)
           为奇数的格子翻转颜色,那样就可以转换成全是一样颜色了,然后边成把(i+j)为偶数的翻转,四种情况取最大即可。复杂度O(n*m)
*/
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;

const int maxn=1005;
int mat[maxn][maxn],mat1[maxn][maxn],up[maxn][maxn],lef[maxn][maxn],rig[maxn][maxn];
char a[maxn][maxn];
int n,m;
int get()
{
    int ans=0;
    for(int i=0; i<m; i++)
    {
        int lo=-1,ro=n;
        for(int j=0; j<n; j++)
        {
            if(mat[i][j]==1)
            {
                up[i][j]=lef[i][j]=0;
                lo=j;
            }
            else
            {
                up[i][j]=i==0?1:up[i-1][j]+1;
                lef[i][j]=i==0?lo+1:max(lef[i-1][j],lo+1);
            }
        }
        for(int j=n-1; j>=0; j--)
        {
            if(mat[i][j]==1)
            {
                rig[i][j]=n;
                ro=j;
            }
            else
            {
                rig[i][j]=i==0?ro-1:min(rig[i-1][j],ro-1);
                ans=max(ans,up[i][j]*2+2*(rig[i][j]-lef[i][j]+1));
            }
        }
    }
    return ans;
}
int main()
{
    int tt=0,T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0; i<m; i++)
        {
            scanf("%s",a[i]);
        }
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(a[i][j]=='R')
                    mat1[i][j]=mat[i][j]=1;
                else
                    mat1[i][j]=mat[i][j]=0;
            }
        }
        int ans=-1;
        ///1
        ans=max(ans,get());
        ///2
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                if(mat1[i][j]==1)
                    mat[i][j]=0;
                else
                    mat[i][j]=1;
            }
        }
        ans=max(ans,get());
        ///3
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                if((i+j)%2==1)
                {
                    if(mat1[i][j]==1)
                        mat[i][j]=0;
                    else
                        mat[i][j]=1;
                }
                else
                    mat[i][j]=mat1[i][j];
            }
        }
       /* for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                printf("%d",mat[i][j]);
            }
            printf("\n");
        }
        printf("\n");*/
        ans=max(ans,get());
        ///4
        for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                if((i+j)%2==0)
                {
                    if(mat1[i][j]==1)
                        mat[i][j]=0;
                    else
                        mat[i][j]=1;
                }
                else
                    mat[i][j]=mat1[i][j];
            }
        }
        /*for(int i=0; i<m; i++)
        {
            for(int j=0; j<n; j++)
            {
                printf("%d",mat[i][j]);
            }
            printf("\n");
        }
        printf("\n");*/
        ans=max(ans,get());
        printf("Case #%d: %d\n",++tt,ans);
    }
    return 0;
}
/**
100
3 3
BBR
RBR
BBB

2 2
BR
RB

2 2
BB
RR

2 2
BB
BB
*/
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧农业是一种结合了现代信息技术,包括物联网、大数据、云计算等,对农业生产过程进行智能化管理和监控的新模式。它通过各种传感器和设备采集农业生产中的关键数据,如大气、土壤和水质参数,以及生物生长状态等,实现远程诊断和精准调控。智慧农业的核心价值在于提高农业生产效率,保障食品安全,实现资源的可持续利用,并为农业产业的转型升级提供支持。 智慧农业的实现依赖于多个系统,包括但不限于设施蔬菜精细化种植管理系统、农业技术资料库、数据采集系统、防伪防串货系统、食品安全与质量追溯系统、应急追溯系统、灾情疫情防控系统、农业工作管理系统、远程诊断系统、监控中心、环境监测系统、智能环境控制系统等。这些系统共同构成了一个综合的信息管理和服务平台,使得农业生产者能够基于数据做出更加科学的决策。 数据采集是智慧农业的基础。通过手工录入、传感器自动采集、移动端录入、条码/RFID扫描录入、拍照录入以及GPS和遥感技术等多种方式,智慧农业系统能够全面收集农业生产过程中的各种数据。这些数据不仅包括环境参数,还涵盖了生长状态、加工保存、检验检疫等环节,为农业生产提供了全面的数据支持。 智慧农业的应用前景广阔,它不仅能够提升农业生产的管理水平,还能够通过各种应用系统,如库房管理、无公害监控、物资管理、成本控制等,为农业生产者提供全面的服务。此外,智慧农业还能够支持政府监管,通过发病报告、投入品报告、死亡报告等,加强农业产品的安全管理和质量控制。 面对智慧农业的建设和发展,存在一些挑战,如投资成本高、生产过程标准化难度大、数据采集和监测的技术难题等。为了克服这些挑战,需要政府、企业和相关机构的共同努力,通过政策支持、技术创新和教育培训等手段,推动智慧农业的健康发展。智慧农业的建设需要明确建设目的,选择合适的系统模块,并制定合理的设备布署方案,以实现农业生产的智能化、精准化和高效化。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值