hdu4612 连通性,求树的直径,加一边求最少桥

http://acm.hdu.edu.cn/showproblem.php?pid=4612



Problem Description
  N planets are connected by M bidirectional channels that allow instant transportation. It's always possible to travel between any two planets through these channels.
  If we can isolate some planets from others by breaking only one channel , the channel is called a bridge of the transportation system.
People don't like to be isolated. So they ask what's the minimal number of bridges they can have if they decide to build a new channel.
  Note that there could be more than one channel between two planets.
 

Input
  The input contains multiple cases.
  Each case starts with two positive integers N and M , indicating the number of planets and the number of channels.
  (2<=N<=200000, 1<=M<=1000000)
  Next M lines each contains two positive integers A and B, indicating a channel between planet A and B in the system. Planets are numbered by 1..N.
  A line with two integers '0' terminates the input.
 

Output
  For each case, output the minimal number of bridges after building a new channel in a line.
 

Sample Input
  
  
4 4 1 2 1 3 1 4 2 3 0 0
 

Sample Output
  
  
0
 

Source


/**
hdu4612  连通性,求树的直径,加一边求最少桥
题目大意:给定一个无向连通图加上一条边后所得到的图所含的桥的数目最少
解题思路:tarjan缩点边树,求出树的直径m,则原有桥数-m即为所求。
           本题要注意考虑重边和注意求树的直径的方法(见代码注释)
           *直径:;任意两个节点之间的最长距离
*/
#pragma comment(linker, "/STACK:1024000000,1024000000")///申请空间
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <vector>
using namespace std;
const int maxn=200010;
const int maxm=2000014;

struct note
{
    int v,next;
    bool cut,chong_bian;
} edge[maxm];

int head[maxn],ip;
int n,m;

void init()
{
    memset(head,-1,sizeof(head));
    ip=0;
}
void addedge(int u,int v,bool chong_bian)
{
    edge[ip].v=v,edge[ip].cut=false,edge[ip].chong_bian=chong_bian,edge[ip].next=head[u],head[u]=ip++;
}

int dfn[maxn],low[maxn],dex,inst[maxn],st[maxn],top,cnt,belong[maxn];

void tarjan(int u,int pre,bool ff)///ff代表重边
{
    dfn[u]=low[u]=++dex;
    st[top++]=u;
    inst[u]=1;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].v;
        if(v==pre&&(!ff))continue;///与没有重边的区别
        if(!dfn[v])
        {
            tarjan(v,u,edge[i].chong_bian);
            if(low[u]>low[v])low[u]=low[v];
            if(low[v]>dfn[u])
            {
                ///bridge++;
                edge[i].cut=true;
                edge[i^1].cut=true;
            }
        }
        else if(inst[v]&&dfn[v]<low[u])
        {
            low[u]=dfn[v];
        }
    }
    if(dfn[u]==low[u])
    {
        cnt++;
        int v;
        do
        {
            v=st[--top];
            inst[v]=0;
            belong[v]=cnt;
        }
        while(v!=u);
    }
}

vector <int> vec[maxn];
int dep[maxn];

void dfs(int u)///dfs求每个节点的深度
{
    for(int i=0; i<vec[u].size(); i++)
    {
        int v=vec[u][i];
        if(dep[v]!=-1)continue;
        dep[v]=dep[u]+1;
        dfs(v);
    }
}

void solve()
{
    memset(dfn,0,sizeof(dfn));
    memset(inst,0,sizeof(inst));
    cnt=dex=top=0;
    tarjan(1,0,false);
    for(int i=1;i<=cnt;i++)
        vec[i].clear();
    for(int u=1; u<=n; u++)
    {
        for(int i=head[u]; i!=-1; i=edge[i].next)
        {
            if(edge[i].cut)
            {
                int v=edge[i].v;
                vec[belong[u]].push_back(belong[v]);
            }
        }
    }
    ///=======求直径=========
    memset(dep,-1,sizeof(dep));
    dep[1]=0;
    dfs(1);
    int k=1;
    for(int i=1; i<=cnt; i++)
    {
        if(dep[i]>dep[k])
            k=i;
    }
    memset(dep,-1,sizeof(dep));
    dep[k]=0;
    dfs(k);
    int ans=0;
    for(int i=1; i<=cnt; i++)
    {
        ans=max(ans,dep[i]);
    }
    ///=======================
    printf("%d\n",cnt-1-ans);
}

struct note_
{
    int x,y;
} node[maxm];

bool cmp(note_ a,note_ b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)break;
        for(int i=0; i<m; i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            if(u==v)continue;
            if(u>v)swap(u,v);
            node[i].x=u;
            node[i].y=v;
        }
        sort(node,node+m,cmp);
        init();
        for(int i=0; i<m; i++)
        {
            if(i==0||(node[i].x!=node[i-1].x||node[i].y!=node[i-1].y))
            {
                if(i<m-1&&node[i].x==node[i+1].x&&node[i].y==node[i+1].y)
                {
                    addedge(node[i].x,node[i].y,true);
                    addedge(node[i].y,node[i].x,true);
                }
                else
                {
                    addedge(node[i].x,node[i].y,false);
                    addedge(node[i].y,node[i].x,false);
                }
            }
        }
        solve();
    }
    return 0;
}

好的,关于 HDU4992 所有原根的问题,我可以给出以下解答: 1. 首先,我们需要知道什么是原根。原根是指模 n 意义下,所有与 n 互质的数 a 的最小正整数 k 次幂对 n 取模的值覆盖了所有与 n 互质的数。简单来说,就是如果一个数 a 是模 n 意义下的原根,那么 a 的任何正整数次幂对 n 取模的值都不相同,且能覆盖所有与 n 互质的数。 2. 为了模 n 意义下的所有原根,我们需要先出与 n 互质的数的个数 phi(n)。phi(n) 可以使用欧拉函数出。 3. 然后,我们需要枚举模 n 意义下的所有数,判断它是否是原根。具体来说,对于每个 a,我们需要判断 a 的每个小于 phi(n) 的正整数次幂对 n 取模的值是否都不相同,且能覆盖所有与 n 互质的数。如果是,那么 a 就是模 n 意义下的原根。 4. 代码实现可以参考以下 Java 代码: ``` import java.util.*; public class Main { static int gcd(int a, int b) { return b == 0 ? a : gcd(b, a % b); } static int phi(int n) { int res = n; for (int i = 2; i * i <= n; i++) { if (n % i == 0) { res = res / i * (i - 1); while (n % i == 0) { n /= i; } } } if (n > 1) { res = res / n * (n - 1); } return res; } static int pow(int a, int b, int mod) { int res = 1; while (b > 0) { if ((b & 1) != 0) { res = res * a % mod; } a = a * a % mod; b >>= 1; } return res; } static boolean check(int a, int n, int phi) { for (int i = 1, j = pow(a, i, n); i <= phi; i++, j = j * a % n) { if (j == 1) { return false; } } return true; } public static void main(String[] args) { Scanner scanner = new Scanner(System.in); while (scanner.hasNext()) { int n = scanner.nextInt(); int phi = phi(n); List<Integer> ans = new ArrayList<>(); for (int i = 1; i < n; i++) { if (gcd(i, n) == 1 && check(i, n, phi)) { ans.add(i); } } Collections.sort(ans); for (int x : ans) { System.out.print(x + " "); } System.out.println(); } } } ``` 其中,gcd 函数用于最大公约数,phi 函数用于欧拉函数,pow 函数用于快速幂模,check 函数用于判断一个数是否是原根。在主函数中,我们依次读入每个 n,出 phi(n),然后枚举模 n 意义下的所有数,判断它是否是原根,将所有原根存入一个 List 中,最后排序输出即可。 希望我的回答能够帮到你,如果你有任何问题,欢迎随时提出。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值