Android程序报错:程序包org.apache.http不存在——Android 6.0已经不支持HttpClient

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/lvyoujt/article/details/51645176

Android Studio 2.1中使用 Android SDK 6.0(API 23),加载融云Demo时,报错:





解决办法:

1、eclipse

libs中加入
org.apache.http.legacy.jar
上面的jar包在:**\android-sdk-windows\platforms\android-23\optional下(需要下载android 6.0的SDK)

2、Android Studio

Android 6.0(api 23)已经不支持HttpClient了,在build.gradle中 加入 useLibrary 'org.apache.http.legacy'就可以了,如图:


展开阅读全文

没有更多推荐了,返回首页