最短路 ~Interesting Calculator 湖南省第九届程序设计竞赛

1336: Interesting Calculator

            Time Limit: 2 Sec       Memory Limit: 128 Mb       Submitted: 858       Solved: 210    

Description

There is an interesting calculator. It has 3 rows of buttons.

 

Row 1: button 0, 1, 2, 3, ..., 9. Pressing each button appends that digit to the end of the display.

Row 2: button +0, +1, +2, +3, ..., +9. Pressing each button adds that digit to the display.

Row 3: button *0, *1, *2, *3, ..., *9. Pressing each button multiplies that digit to the display.

 

Note that it never displays leading zeros, so if the current display is 0, pressing 5 makes it 5 instead of 05. If the current display is 12, you can press button 3, +5, *2 to get 256. Similarly, to change the display from 0 to 1, you can press 1 or +1 (but not both!).

 

Each button has a positive cost, your task is to change the display from x to y with minimum cost. If there are multiple ways to do so, the number of presses should be minimized.

Input

There will be at most 30 test cases. The first line of each test case contains two integers x and y(0<=x<=y<=105). Each of the 3 lines contains 10 positive integers (not greater than 105), i.e. the costs of each button.

Output

For each test case, print the minimal cost and the number of presses.

Sample Input

12 256
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
12 256
100 100 100 1 100 100 100 100 100 100
100 100 100 100 100 1 100 100 100 100
100 100 10 100 100 100 100 100 100 100

Sample Output

Case 1: 2 2
Case 2: 12 3
思路:最短路算法
#include<stdio.h>
#include<queue>
#include<string.h>
using namespace std;
#define MAX 100010
int n,m;
int map[5][30];
int  dis[MAX];
int way[MAX];
int count;
void bfs()
{
    for(int i=0;i<=100009;i++)
        dis[i]=999999999;
    memset(way,0,sizeof(way));
    queue<int>q;
    int a=n;
    q.push(a);
    dis[n]=0;
    while(!q.empty())
    {
        a=q.front();
        q.pop();
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<=9;j++)
            {  int b=a;
                if(i==0)
                {
                   b=b*10+j;
                }
                else if(i==1)
                {
                    b=b+j;

                }
                 else
                {

                    b=b*j;

                }
                if(b>m) continue;
               if(dis[b]<=dis[a]+map[i][j]) continue;
                dis[b]=dis[a]+map[i][j];
                 way[b]=way[a]+1;
                 q.push(b);

            }
        }
    }

            printf("Case %d: %d %d\n",count++,dis[m],way[m]);


}
int main()
{   count=1;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<=9;j++)
              { scanf("%d",&map[i][j]);
                 // printf("a\n");
            }

        }
        bfs();
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值