bzoj1008: [HNOI2008]越狱
Description
监狱有连续编号为1...N的N个房间,每个房间关押一个犯人,有M种宗教,每个犯人可能信仰其中一种。如果相邻房间的犯人的宗教相同,就可能发生越狱,求有多少种状态可能发生越狱
Input
输入两个整数M,N.1<=M<=10^8,1<=N<=10^12
Output
可能越狱的状态数,模100003取余
Sample Input
2 3
Sample Output
6
HINT
6种状态为(000)(001)(011)(100)(110)(111)
Source
题解:
真心水的一道题目。。
从反面考虑不会导致越狱的种数
很显然是n*(n-1)*(n-1)......(第一个由于前面没有相邻的,数量为n)
此题n会很大,在来个快速幂就OK了。。
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
const int M=100003;
long long n,m,ans;
long long power(long long x,long long y)
{
long long ans=1;
while(y)
{
if(y&1) ans=ans*x%M;
x=x*x%M;
y>>=1;
}
return ans;
}
int main()
{
cin>>n>>m;
ans=power(n,m);
ans=(ans-power(n-1,m-1)*n%M+M)%M;
cout<<ans;
return 0;
}