POJ 1742 Coins (dp)

Coins
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 29974 Accepted: 10171

Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch. 
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins. 

Input

The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.

Output

For each test case output the answer on a single line.

Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

多重背包二进制优化

AC代码如下:

//
//  POJ 1742 Coins
//
//  Created by TaoSama on 2015-03-05
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, m, w[105], c[105];
bool dp[N];

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n >> m && n && m) {
		for(int i = 1; i <= n; ++i)  cin >> w[i];
		for(int i = 1; i <= n; ++i)  cin >> c[i];
		memset(dp, false, sizeof dp);
		dp[0] = true;
		for(int i = 1; i <= n; ++i) {
			int k = 1;
			while(c[i] > 0) {
				int v = w[i] * min(k, c[i]);
				for(int j = m; j >= v; --j)
					dp[j] |= dp[j - v];
				c[i] -= k; k <<= 1;
			}
		}
		cout << count(dp + 1, dp + 1 + m, true) << endl;
	}
	return 0;
}


另一种做法 根据挑战书上多重部分和问题 dp[i][j]表示 前i种物品加和成j 所余i物品的最多个数

如果已经前i-1个物品可以加和成j即dp[i-1][j]>=0  那么dp[i][j] = c[i]

如果无法加和或者i个物品用完了即j<w[i]或者dp[i][j-w[i]]<=0 那么dp[i][j] = -INF;

其他情况减少一个即可  dp[i][j] = dp[i][j-w[i] -1;

AC代码如下:

//
//  POJ 1742 Coins
//
//  Created by TaoSama on 2015-03-05
//  Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))

using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e5 + 10;

int n, m, w[105], c[105], dp[N];

int main() {
#ifdef LOCAL
	freopen("in.txt", "r", stdin);
//	freopen("out.txt","w",stdout);
#endif
	ios_base::sync_with_stdio(0);

	while(cin >> n >> m && n && m) {
		for(int i = 1; i <= n; ++i)  cin >> w[i];
		for(int i = 1; i <= n; ++i)  cin >> c[i];
		memset(dp, 0xc0, sizeof dp);
		dp[0] = 0;
		for(int i = 1; i <= n; ++i) {
			for(int j = 0; j <= m; ++j) {
				if(dp[j] >= 0) dp[j] = c[i];
				else if(j < w[i] || dp[j - w[i]] <= 0) dp[j] = -INF;
				else	dp[j] = dp[j - w[i]] - 1;
			}
		}
		int ans = 0;
		for(int i = 1; i <= m; ++i) if(dp[i] >= 0) ++ans;
		cout << ans << endl;
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值