lake counting---dfs(深度搜索算法)

问题描述

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.
输入描述
* Line 1: Two space-separated integers: N and M * Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
输出描述
* Line 1: The number of ponds in Farmer John's field.
样例输入
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
样例输出

3

题目分析:

dfs实际上就是一直顺着一个方向不断地搜索直到搜索到头为止。并且在搜索的过程中,要进行标记,防止走过得路重复走。

以第一个点'W'点为例,以这个为节点分别向八个方向搜索,遇到新的'W'点时,在以这个新的'W'点为节点分别向八个方向搜索,不断递归,把一块区域搜索完。(0,0)--(1,1)--(1,2)--(1,3)--(2,4)--(2,5)一块区域搜索完毕。

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int dx[8]={0,0,1,1,-1,-1,1,-1};
int dy[8]={1,-1,1,-1,-1,1,0,0};
char mp[102][102];
int node[102][102];///标记数组,走过的路就不要在走了,否则会陷入死循环。
int num,n,m;
void dfs(int x,int y)
{
    int i,x1,y1;
    if(x<0||y<0||x>=n||y>=m) return;
    if(mp[x][y]=='.') return;
    node[x][y]=1;
    for(i=0;i<8;i++)///对八个方向进行搜索。
    {
        x1=x+dx[i];
        y1=y+dy[i];
        if(mp[x1][y1]=='W'&&node[x1][y1]==0) dfs(x1,y1);
    }
}
int main()
{
    int i,j;
    ///scanf("%d%d",&n,&m);
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        num=0;
        memset(node,0,sizeof(node));///对标记数组进行初始化。
        for(i=0; i<n; i++)
        {
            scanf("%s",mp[i]);
        }
        ///深度搜索,对数组进行遍历。
        for(i=0; i<n; i++)
        {
            for(j=0; j<m; j++)
            {
                if(node[i][j]==0&&mp[i][j]=='W')
                {
                    dfs(i,j);
                    num++;///用来表示有没有连通的区域
                }
            }
        }
        printf("%d\n",num);
    }
 return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值