Exponentiation

题目链接
POJ 1001 Exponentiation
Description
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.
This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don’t print the decimal point if the result is an integer.

Sample Input
95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

Sample Output
548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201


#include<iostream>
#include<string>
using namespace std;

void mul(string &a, string &b)
{
    int i, j, k, c;
    int n1 = a.size(), n2 = b.size();
    string res;
    char aa[300];//一开始是直接赋给A的。可是有莫名其妙的错误。后来就开个char数组。
    res.resize(n1 + n2);
    for (i = 0; i<res.size(); i++)
        res[i] = 0;
    for (i = 0; i<n1; i++)
    {
        for (j = k = 0; j<n2; j++)//高精度X
        {
            c = (a[n1 - i - 1] - '0')*(b[n2 - j - 1] - '0') + k;

            res[i + j] += c;

            k = res[i + j] / 10;
            res[i + j] %= 10;
        }
        if (k)
            res[i + j] = k;

    }
    for (i = res.size() - 1; i>0 && res[i] == 0; i--)//清除0;
        res.erase(i, 1);
    for (i = 1; i <= res.length(); i++)
    {
        aa[i - 1] = (char)(res[res.length() - i] + '0');//反转,存储
    }

    aa[i - 1] = 0;

    a = string(aa);//赋值

}


int main()
{
    int n, i, j, pos;
    string in;


    while (cin >> in >> n)
    {
        for (pos = 0, i = 0; i<in.size(); i++)
        if (in[i] == '.')break;

        pos = in.size() - i - 1;//记录小数点位置。

        in.erase(i, 1);//在位置i删除长度为1的字符,就是删除小数点。

        string res("1"); 
        for (i = 0; i < n; i++) mul(res, in);

        if (pos != -1)pos = n * pos;

        while (res.size() < pos)

            res.insert(res.begin(), '0');//若长度小于精度,在前面添0

        if (pos != -1)
        {
            res.insert(res.end() - pos, '.');//插入小数点
            for (i = res.length() - 1; res[i] == '0'; i--);//除去多余的0;
            res.erase(i + 1);
            if (res[i] == '.')res.erase(i);//若是整数,除去小数点。
        }
        cout << res << endl;
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值