poj 2689 Prime Distance

Prime Distance

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15734 Accepted: 4179

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.

There are no adjacent primes.

 

题意:

给你一段区间,要你区间内,连续的最近的两个素数和最远的两个素数

解法:

由于所给的区间的值会很大,所以我们不能直接用筛法解决,这里我们可以找出前50000个素数,作为我们的因子来判断我们区间

内的数是不是素数,利用筛法,这样就大大提高了效率。为什么是50000呢,因为50000*50000>2,147,483,647.

 

ac代码:

 

#include <iostream>
#include <cstdio>
#include <set>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cmath>
#include <map>
#include <string>
#include <cctype>
using namespace std;
typedef __int64 LL;
const int maxn = 1e6+10;
LL prime[maxn];
bool sign[maxn];
LL len;
void init()
{
    memset(sign,false,sizeof(sign));
    sign[0]=sign[1]=true;
    for(int i=2 ; i<50100; i++)
        if(!sign[i])
        {
            if(i>50100/i) continue;
            for(int j=i*i; j<50100; j+=i)
            {
                sign[j]=true;
            }
        }
    len=0;
    for(int i=2; i<50100; i++)
    {
        if(!sign[i]) prime[len++]=i;
    }
}

int main()
{
    init();
    LL l,r;
    while(~scanf("%I64d%I64d",&l,&r))
    {
        memset(sign,false,sizeof(sign));
        LL s,e;
        for(int i=0; i<len; i++)
        {
            s=(l/prime[i]+(l%prime[i]!=0))*prime[i];
            e=(r/prime[i])*prime[i];
            //  cout<<s<<" "<<e<<" "<<prime[i]<<endl;
            for(LL j=s; j<=e; j+=prime[i])
            {
                if(j!=prime[i])
                    sign[j-l]=true;
            }
        }
        LL sum=10000100,last=-1,left,right;
        for(LL i=l; i<=r; i++)
        {
            if(i==1) continue;
            if(!sign[i-l])
            {
                if(last==-1)
                {
                    last=i;
                }
                else
                {
                    if(sum>i-last)
                    {
                        sum=i-last;
                        left=last;
                        right=i;
                    }
                    last=i;
                }
            }
        }
        if(sum==10000100)
        {
            printf("There are no adjacent primes.\n");
            continue;
        }
        printf("%I64d,%I64d are closest, ",left,right);
        sum=-1,last=-1;
        for(LL i=l; i<=r; i++)
        {
            if(i==1) continue;
            if(!sign[i-l])
            {
                if(last==-1)
                {
                    last=i;
                }
                else
                {
                    if(sum<i-last)
                    {
                        sum=i-last;
                        left=last;
                        right=i;
                    }
                    last=i;
                }
            }
        }
        printf("%I64d,%I64d are most distant.\n",left,right);
    }
    return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值