lightoj 1030 discovering gold(概率dp)

 

B - Discovering Gold

Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

 

Description

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

 

1

101

 

2

10 3

 

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

 

 

 

题意:有一个长的山洞,我们从1点出发,每次掷六面的骰子,来决定走几步,每当我们走到一个位置时,我们可以拿到那个位置所有的黄金,问走到末尾顶点时收集到的黄金的数量的期望。

 

分析:

(1)我们可以单独求每一个点对期望的贡献值,也就是算出到达每个点的概率*v[i](当前点的黄金数量)的和。 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<vector>

#define F first
#define S second
#define mp make_pair
using namespace std;
typedef __int64 LL;
const int maxn = 1e5+10;

double h[110];
double dp[110];
int main()
{
    int T,n,u=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%lf",&h[i]);
        memset(dp,0,sizeof(dp));
        double sum=0 ;
        dp[1]=1;
        for(int i=1;i<=n;i++)
        {
            int maxx=min(n,i+6);
            for(int j=i+1;j<=maxx;j++)
            {
                dp[j]+=dp[i]/(maxx-i);
            }
        }
        for(int i=1;i<=n;i++)
        {
            sum+=dp[i]*h[i];
        }
        printf("Case %d: %f\n",u++,sum);
    }
    return 0 ;
}

 

 

(2)我们可以用dp[i]来表示当前位置i到位置n的期望值。
 

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<vector>

#define F first
#define S second
#define mp make_pair
using namespace std;
typedef __int64 LL;
const int maxn = 1e5+10;

double h[110];
double dp[110];
int main()
{
    int T,n,u=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%lf",&h[i]);
        memset(dp,0,sizeof(dp));
        dp[n]=h[n];
        for(int i=n;i>=1;i--)
        {
            int maxx=min(i+6,n);
            for(int j=i+1;j<=maxx;j++)
            {
                dp[i]+=(dp[j]+h[i])/(maxx-i);
            }
        }
        printf("Case %d: %f\n",u++,dp[1]);
    }
    return 0 ;
}

 

 

 

 

 

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值