POJ 2488 A Knight's Journey

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board. Input The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, … , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, …

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. If no such path exist, you should output impossible on a single line.

Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

因为要使输出是字典序最小,所以要在方向上注意一下。
比较简单的dfs,因为第一次看错题了可能有些多余的语句。
中间练习了一下重载和栈。

#include<iostream>  
#include<stack>
using namespace std;
bool map[30][30];
bool flag;
struct point
{
    int x;
    int y;
    point(){x=0;y=0;}
    char *str() const
    {
        char str[4]={0};
        sprintf(str,"%c%d",x+'A'-1,y);
        return str;
    }
};
ostream& operator << (ostream &out, const point& x)
{
    for(int i=0;*(x.str()+i)!=0;i++)
        out << *(x.str()+i);
    return out;
}
stack<point>s,q;
int x1,y1;
int b;
int direction[8][2]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};
void dfs(int x,int y)
{
    point pnt;
    pnt.x=x;
    pnt.y=y;
    s.push(pnt);
    b++;
    if(b==x1*y1)
        flag=false;
    if(!flag)
        return;
    for(int i=0;i<8;i++)
    {
        pnt.x=x+direction[i][0];
        pnt.y=y+direction[i][1];
        if(0 < pnt.x&& pnt.x <= x1&& 0 < pnt.y&& pnt.y <= y1&& map[pnt.x][pnt.y]&& flag)
        {
            map[pnt.x][pnt.y]=false;
            dfs(pnt.x,pnt.y);
            if(!flag)
                return;
            s.pop();
            b--;
            map[pnt.x][pnt.y]=true;
        }

    }
}
int main()
{
    point pnt;
    int a;
    cin>>a;
    int num=0;
    while(a--)
    {
        num++;
        flag=true;
        memset(map,true,sizeof(map));
        cin>>y1>>x1;
        map[1][1]=false;
        b=0;
        dfs(1,1);
        cout<<"Scenario #"<<num<<":"<<endl;
        if(flag)
        {
            cout<<"impossible"<<endl;
        }
        else
        {
            while(!s.empty())
            {
                q.push(s.top());
                s.pop();
            }
            while(!q.empty())
            {
                cout<<q.top();
                q.pop();
            }
            cout<<endl;
        }
        while(!s.empty())
        {
            s.pop();
        }
        if(a)
            cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值